Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

Hide '/website/info' page

By
Mario Gielissen | Openworx
on 10/6/14, 5:06 PM 3,597 views

De URL '/website/info' show information about the installed modules in 8.0.  There is a notify on the page "Note: To hide this page, uncheck it from the top Customize menu.", but I can't find this option.

2
Kelly Stuart
On 10/30/14, 1:07 AM

Hi Mario. It does seem like Fabien's approach should work, but there is a modifier that requires Active to be True. So here's an alternative approach until the Customize Menu is modified.

Go to Settings - User Interface - Views. Now search for "Odoo Information". That's the view you want to check off to make inactive, but it won't let you. So what I did instead was to turn the first and last div tags into comments. (You can't do it any higher up because the framework is expecting those template tags to build the page.) The end result is a plain website with all of the /website/info information hidden. It's certainly not the most elegant solution, but it is quick and it works.

I hope this helps. Good luck!

1
Bruno JOLIVEAU
On 2/5/15, 10:15 PM

Hi,

I think this addons will help you

https://github.com/savoirfairelinux/website/tree/8.0-website_menu_display/website_menu_by_user_status

(from https://www.odoo.com/forum/help-1/question/how-to-hide-the-shop-for-unregistered-users-74859)

0
Laura
On 1/5/16, 6:02 AM

Hi, Mario

Do you have been able to disable the page /website/info?? 


- I tried to go " Settings - User Interface - Views. and go to "Odoo Information"." But this view doesn't exist.
I tried to installed the module oerp_no_website_info but it doesn't work because is a copy from " /addons/website/controllers/main.py" Line 143. And it doesn't do nothing.

- I tried to uncheck it from the top Customize menu.", but this option doesn't exist on Odoo 8.



How it's possible hide this view (/website/info)????

Any help, please???
0
Ruben
On 12/4/15, 3:50 AM

Checkout Configuration -- Views -- Footer Copyright and uncheck it. Or re-use code to place your ad if you please.

0

Fabien Pinckaers (fp)

--Fabien Pinckaers (fp)--
6598
| 6 8 8
fsdsdfsdf, Belgium
--Fabien Pinckaers (fp)--

Odoo Founder & CEO

Fabien Pinckaers (fp)
On 10/7/14, 2:27 AM

You can uncheck 'active' field on the view. We developed a fault tolerant controller that allows this.

We will fix to make it appear in customize menu

Unchecked active, yet the page still shows? What did I do wrong?

John Baldwin
on 10/7/14, 3:42 AM

@John, confirmed but you can edit de view en remove the information code as a workaround.

Mario Gielissen | Openworx
on 10/7/14, 4:14 AM

@Fabien,

I just saw this PR waiting to be merged into 8.0 that fixes the issue:

https://github.com/odoo/odoo/pull/6199

Thanks!

Luke Branch
on 4/8/15, 6:09 AM
0
Ruchir Shukla
On 2/21/15, 8:06 AM

Please checkout module to make website info page as private 

https://bitbucket.org/BizzAppDev/oerp_no_website_info 

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

4 follower(s)

Stats

Asked: 10/6/14, 5:06 PM
Seen: 3597 times
Last updated: 1/5/16, 6:02 AM