Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Help Needed, OpenERP Trunk (8) Service Can't Start

By
Johan
on 10/22/13, 12:40 AM 4,900 views

I just download the latest trunk version (all in one) today and start to install. After finish installed, I can not access the software with my firefox because the services can not automatically started. After I manually start it with services.msc it stop again after started. What I have miss here? Please help.

Check your log files for errors, something may be preventing Postgres from starting. Unfortunately I don't know where those are on Windows.

Brett Lehrer
on 10/22/13, 12:56 AM

On Ubuntu and Debian installing OpenERP 8dev current trunk version is very easy - to get it working is an endless journey - unfortunately!

Step 1: Put this into our /etc/apt/souces.list.d/openerp.list (or create it)

 deb <a href="http://nightly.openerp.com/trunk/nightly/deb/">http://nightly.openerp.com/trunk/nightly/deb/</a> ./

Step 2: Apply the new changes in sources.list

apt-get update

Step 3: Install OpenERP Version 8.0dev from Trunk

apt-get install openerp

You need to read on in the next comment as the censorship of the commenting system is cutting of the rest.

Andi Becker
on 4/5/14, 8:06 AM

Step 4: type in your browser the domain and add the port :8069

<a href="http://mydomain.tld:8069">http://mydomain.tld:8069</a>

or IP-Address + Port :8069

<a href="http://123.456.789.012:8069">http://123.456.789.012:8069</a>

PROBLEM: OpenERP Version 8 is not working? Why not? Answers are more than welcome!

Some might like to answer that postgres is not working etc but it is as Version 7 is working! Test it out!

Step 5: Remove OpenERP Debian Package Version 8

apt-get remove openerp

You need to read on in the next comment as the censorship of the commenting system is cutting of the rest.

Andi Becker
on 4/5/14, 8:07 AM

Step 6: Change the OpenERP Version in your sources.list file from "trunk" to "7.0" Apply the following changes in your /etc/apt/sources.list.d/openerp.list file

deb <a href="http://nightly.openerp.com/7.0/nightly/deb/">http://nightly.openerp.com/7.0/nightly/deb/</a> ./

Step 7: Update the sources

apt-get update

Step 8: Install OpenERP Version 7

apt-get install openerp

Step 9: Open OpenERP in your browser

<a href="http://mydomain.tld:8069">http://mydomain.tld:8069</a>

or IP-Address + Port :8069

<a href="http://123.456.789.012:8069">http://123.456.789.012:8069</a>

You need to read on in the next comment as the censorship of the commenting system is cutting of the rest.

Andi Becker
on 4/5/14, 8:08 AM

HURRAY for OpenERP 7.0 it is working! but you don't have the website builder :-(

Now you can start with Step 1 again and test Version 8 again and it won't work!

Please give me a reason why OpenERP 7 is working and OpenERP is not at all working since meanwhile 1 1/2 months! if installed from the Debain Package!

Does the package still get maintained. If yes who is maintaining it! Can we contact this person or company! Thanks!

You need to read on in the next comment as the censorship of the commenting system is cutting of the rest.

Andi Becker
on 4/5/14, 8:08 AM

A Debian Package is and should actually install all dependencies and it did it before but it seems as if right now something has changed in that package. We tested this problem on all Ubuntu and Debian distributions which are available on DigitalOcean and on our Dedicated Server running on up to date Debian 7 too. This problem can be reproduced with all available Versions of Ubuntu or Debian. OpenERP 8 is simply not working!

Andi Becker
on 4/5/14, 8:17 AM

Additional Remark to the maintainers of this OpenERP System!

  1. Your system is showing very often an NGINX ERROR 502 which makes answering a hazzle
  2. Collaborating with others is very difficult when you have no chance to post a solution because your karma - or however you might call it is not sufficient. Either you want to have people collaborating and posting solutions - than please let them post their solutions or tell them right the way that only people with karma +100 are welcome!

It is not racism but very similar - I would call it karmarism - just another form of discriminating people

Andi Becker
on 4/5/14, 8:21 AM
  1. A commenting system is not worth in commenting in when you can only post a certain amount of solutions.

By the way I wrote 3. but your censorship is changing it again to 1.!!! which is simply WRONG!

Your system should not change things what people have entered as solutions or additional comments as you might transform a correct statement into an incorrect one!

Andi Becker
on 4/5/14, 8:21 AM

You can also do a dist-upgrade and it won't work

root@vm / # apt-get dist-upgrade Reading package lists... Done Building dependency tree
Reading state information... Done Calculating upgrade... Done The following NEW packages will be installed: python-oauthlib python-requests python-six The following packages will be upgraded: openerp 1 upgraded, 3 newly installed, 0 to remove and 0 not upgraded. Need to get 0 B/107 MB of archives. After this operation, 69.8 MB of additional disk space will be used. Do you want to continue [Y/n]? Y

Andi Becker
on 4/5/14, 8:30 AM

WARNING: The following packages cannot be authenticated! openerp Install these packages without verification [y/N]? y

Andi Becker
on 4/5/14, 8:30 AM
0
Andi Becker
On 4/5/14, 8:16 AM

Could not post our solution, because your karma is insufficient to publish links

Therefore please contact us if you want to have a working OpenERP 8 - Thanks!

0

Jagdish Panchal

--Jagdish Panchal--
2674
| 5 3 6
Gandhinagar, India
--Jagdish Panchal--

OpenERP Developer

Jagdish Panchal
On 4/5/14, 8:37 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 10/22/13, 12:40 AM
Seen: 4900 times
Last updated: 3/16/15, 8:10 AM