Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Help me to learn Webservice connection....?

By
Anand
on 12/4/14, 4:08 AM 768 views

Actually I want to learnt about webservice connection in odoo...

For the 1st step I started with odoo documentation about webservice

https://www.odoo.com/documentation/8.0/api_integration.html

now I want to learn thow o connect odoo with webservices in depth..

please give me some guidance related to it.. Link or doc or tutorial will be more helpfull....

1

Yenthe

--Yenthe--
6721
| 7 7 8
Turnhout, Belgium
--Yenthe--

My Odoo blog: http://www.odoo.yenthevg.com/

My Twitter: https://twitter.com/Yenthe666

Yenthe
On 12/4/14, 4:55 AM

Anand

Sadly there is barely any documentation or any tuts about this. 
You can find an awesome PHP guide here though: http://thierry-godin.developpez.com/openerp/openerp-xmlrpc-php-en/

The link you provided yourself gives the basis for doing it in Java / Android, Ruby, Python & PHP.
If you need more information please specify what you want to do in which language for example. If its about Android I can give you more details.

0
Anand
On 12/4/14, 4:59 AM

Dear yenthe I cant comment in your ans since I have less karma... actually I need to connect website such as magento,amazon with odoo... that is webservice connection...

Ahh sorry I've misunderstood your question then! You can find more about the Magento connector here: http://odoo-magento-connector.com/ and here https://www.odoo.com/nl_NL/forum/help-1/question/magento-connector-odoo-v8-52538 and you can find a lot of details about Amazon etc by searching on "Odoo Amazon connector" for example. I hope this helps you in some way?

Yenthe
on 12/4/14, 5:07 AM

yes... actually I downloaded amazon_connector but it is not working... I cant install it since its asking product_images not found I searched product_images for 2 weeks but i couldn,t find...

Anand
on 12/4/14, 5:11 AM

I *think* you might be talking about this one.. https://code.launchpad.net/~robertolizana/openobject-addons/product_images

Yenthe
on 12/4/14, 5:14 AM

yes... yenthe but it gives error I tried to change the code and tried to made it correct but problem is the model naem itself changed.. Product.image table should be present.. but this module has product_images.image

Anand
on 12/4/14, 6:18 AM

Atlast After some corrections and bugs I have installed amazon connector.. but dont know how to use... :(

Anand
on 12/4/14, 6:32 AM

I'm sorry I can't help you with that, haven't used the connector yet. Try finding some tutorials and if you can't find any or are stuck just ask a new question on this forum!

Yenthe
on 12/4/14, 7:16 AM

okay... Thank you..

Anand
on 12/4/14, 7:47 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 12/4/14, 4:08 AM
Seen: 768 times
Last updated: 3/16/15, 8:10 AM