Help

7

Group access is not working. Any help?

Avatar
Annadurai

    <record id="user_groups_view" model="ir.ui.view">

        <field name="name">res.users.groups.user</field>

        <field name="model">res.users</field>

        <field name="inherit_id" ref="base.view_users_form" />

        <field name="arch" type="xml">

            <field name="partner_id" position="after">

                <field name="user_id" readonly="1" />

                <field name="team_id" readonly="1" />

            </field>

        </field>

    </record>


    <record id="view_users_form_group" model="ir.ui.view">

        <field name="name">res.users.groups.user</field>

        <field name="model">res.users</field>

        <field name="inherit_id" ref="sale_team_acl.user_groups_view" />

        <field name="groups_id" eval="[(6, 0, [ref('sale_team_acl.acl_user_group') ])]" />

        <field name="arch" type="xml">

            <field name="user_id" position="attributes">

                   <attribute name="readonly">0</attribute>

            </field>

            <field name="team_id" position="attributes">

                   <attribute name="readonly">0</attribute>

            </field>

        </field>

    </record>

While enabling the group those fields are not Changing to Editable.. I have defined everything in security XML and csv and its working fine for SO, IO,res.partner but its not working for res.users
1 Comment
Avatar
Discard
Avatar
kirubanidhi
-

Good question

1 Answer
3
Avatar
Annadurai
Best Answer

ahww. It Was solved by reloading the page. 

Avatar
Discard