Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Got an error in every Database i've created, Does anyone here knows how to solve this?

By
Alcaline
on 12/15/14, 2:21 AM 4,602 views

Server Traceback (most recent call last): File "/opt/openerp/server-7/openerp/addons/web/session.py", line 90, in send return openerp.netsvc.dispatch_rpc(service_name, method, args) File "/opt/openerp/server-7/openerp/netsvc.py", line 293, in dispatch_rpc result = ExportService.getService(service_name).dispatch(method, params) File "/opt/openerp/server-7/openerp/service/web_services.py", line 626, in dispatch res = fn(db, uid, *params) File "/opt/openerp/server-7/openerp/osv/osv.py", line 188, in execute_kw return self.execute(db, uid, obj, method, *args, **kw or {}) File "/opt/openerp/server-7/openerp/osv/osv.py", line 131, in wrapper return f(self, dbname, *args, **kwargs) File "/opt/openerp/server-7/openerp/osv/osv.py", line 197, in execute res = self.execute_cr(cr, uid, obj, method, *args, **kw) File "/opt/openerp/server-7/openerp/addons/audittrail/audittrail.py", line 514, in execute_cr return fct_src(cr, uid, model, method, *args, **kw) File "/opt/openerp/server-7/openerp/osv/osv.py", line 185, in execute_cr return getattr(object, method)(cr, uid, *args, **kw) AttributeError: 'module' object has no attribute 'get_apps_server'

It's an error which is caused by Odoo Apps Server - there are problems with connection to that server, which should be resolved sooner than later.

Currenda Sp. z o.o., Mariusz Mizgier
on 12/15/14, 3:12 AM
1

Bole

--Bole--
2385
| 5 4 6
Zagreb | Karlovac, Croatia
--Bole--

there is only 10 kind of people the ones that understand binary ... and others

Bole
On 12/16/14, 5:38 AM

I did not found the proper solution for this error, but i found the workaround:

In order to eliminate this error i installed module disable_openerp_online, wich eliminates all bindings to op-online
for v8 : https://github.com/OCA/server-tools/tree/8.0/disable_openerp_online
for v7: https://github.com/OCA/server-tools/tree/7.0/disable_openerp_online

After this only localy available modules are listed, but no error shows.. 

There is some differencies between versions of openerp downloaded form launchpad and github...
(comment on Hannes Smith anser..) and also, this error appears randomly, not sure when or why... 

thanks Bole

Alcaline
on 12/16/14, 8:06 PM
1
Hannes Smit
On 12/16/14, 2:53 AM

Hi Alcaline,

This is not related to your new database. This method is non-existent in OpenERP 7.0.  It is a ODOO 8 method.

So my idea is that your server calls a service on the openerp's company server. And that reponse tells your server to do stuff that can only be done in ODOO 8.

I think that OpenERP created this bug yesterday.

If you don't like that your server connects to theirs (and sends a bunch of info about your system/database), search for "openerp phone home" on the web.

Well.. just a correction... if you downloaded odoo v7 from github... it does exist... Check openerp/addons/base/module/module.py .. .line 743... the method is actualy there... but still i get the same error... and trying to figure out how to solve it..

Bole
on 12/16/14, 4:21 AM

Thanks Hannes Smit

Alcaline
on 12/16/14, 8:05 PM
0
Ryan Casey
On 1/5/15, 9:13 PM

I was getting the same error, but I found a clean, low-impact solution for it. First off, you're getting that error because of changes to https://apps.openerp.com/loempia/static/src/js/loempia_v7.js that Odoo made recently. I took a look at the version of server/openerp/addons/base/module/module.py in the Github repository ( https://github.com/odoo/odoo/blob/7.0/openerp/addons/base/module/module.py ) and noticed it defined "get_apps_server." So I copied the function definition (reproduced below for convenience) into the copy of module.py in my OpenERP 7 installation and that fixed it.

def get_apps_server(self, cr, uid, context=None):
    return tools.config.get('apps_server', 'https://apps.openerp.com/apps')

However, a better solution for implementations that can afford potentially breaking things would seem to be to completely upgrade your OpenERP 7 installation to match the 7.0 branch on Github. There are a lot of bug fixes that have been added recently.

0
babu
On 12/15/14, 2:46 AM

Hi Lee, Please check the cr_execute menthod in audittrail.py in line 514, I thinks this may be the problem /opt/openerp/server-7/openerp/addons/audittrail/audittrail.py", line 514, in execute_cr return fct_src(cr, uid, model, method, *args, **kw)

thanks Babu

Alcaline
on 12/16/14, 8:06 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

3 follower(s)

Stats

Asked: 12/15/14, 2:21 AM
Seen: 4602 times
Last updated: 3/16/15, 8:10 AM