Help

0

Google OAuth Login not working

Hello!

I have some problem to set up Google Oauth. Here is what I did :

  • Create a Google Console Project (no API activated)

  • Set up an email and a product name for the OAuth screen

  • Get a OAuth Client ID (****.apps.googleusercontent.com)

  • Activate OAuth Authentification in General Settings

  • Paste the OAuth Client ID in Google OAuth2 Provider settings

  • Activate the provider (checkbox)

  • Change the name of the link

Test

  •  "Login with Google"

  • I enter my email (wich is the admin email, only user) and my password

  • I get the following error : "You do not have access to this database or your invitation has expired. Please ask for an invitation and be sure to follow the link in your invitation email."


I guess I forgot something?

Odoo 10.saas~14+e (Enterprise Edition)

Thanks!


Avatar
Discard
2 Answers
0
Avatar
Gino Gervasio
Best Answer

Hey guys,

Using Odoo 12 but found out that you have to resend the invitation email and login with your Google credentials when you verify your email. 

Steps to replicate: Go to `Settings > Users & Companies`, select a user and go to the `OAuth` tab, select `Google OAuth2` and then hit `Re-send invitation email`.

Cheers!

Avatar
Discard
0
Avatar
Alfonso
Best Answer

Hello Félix,

Did you have any solution about the issue, I am fronting the same problem.

Regards.

Avatar
Discard