Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

Google Calendar Sync: Sorry, you are not allowed to modify this document

By
David Dean
on 9/22/14, 5:38 PM 1,507 views

I've successfully linked my Google calendar with Odoo. The problem is when I click "Sync with Google" the following error appears:

AccessError

Sorry, you are not allowed to modify this document. Only users with the following access level are currently allowed to do that:
- Administration/Access Rights

(Document model: res.users)

I've checked the user settings but couldn't find any explicit option to allow Google Calendar sync to start working.

How do I resolve this?

Thanks.

 

Does anyone have any thoughts on how to fix this error? Google Calendar Sync simply doesn't work right now due to this error. Thanks all.

David Dean
on 9/30/14, 6:23 PM
0
David Dean
On 9/26/14, 11:59 AM

I managed to resolve the problem by editing the access control list item:

Settings > Security > Access Controls List

Search for: "res_users" and you should find an an entry called "res_users all"

Click the checkbox to enable Write Access and Save changes

Question: What are the security implications of enabling this option? Although the Google Calendar now syncs, I'm concerned I may have allowed a normal user more access than they should have. Does anyone know?

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 9/22/14, 5:38 PM
Seen: 1507 times
Last updated: 3/16/15, 8:10 AM