Odoo Help


Google Calendar Sync issue with normal account > wrong web.based.url?

Haider Alleg
on 9/21/14, 1:38 PM 2,284 views


Continuing to gets my hand dirty, I found out that once I change in Settings > Technical > Parameters > System Parameters > web.base.url to the correct domain using the administrator account, after playing with a normal account with the calendar sync of Google, it gets back to the previous settings which is the intitial IP of my VPS server.

This is the message I receive with my normal user:

Access Denied

The requested operation cannot be completed due to security restrictions. Please contact your system administrator.

(Document type: Partner, Operation: create)

I am actually facing the issue of having the right domain there, otherwise google calendar sync doesn't work (call back URL is not working with the IP address).

I am on nginx, using a reverse proxy (without ssl) for linking my domain.

Am I missing something? Why the IP adress is coming back again each time I save the settings?

Any help is much more appreciated.


Haider Alleg
On 9/21/14, 2:23 PM

Resolved! Removed public and portal from my test user. Somehow it creates a conflict in rights within odoo. After removing them, no more problem and the URL get fixed within the parameters.

Credits: https://www.odoo.com/forum/help-1/question/access-denied-document-type-partner-operation-read-error-18424

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)


Asked: 9/21/14, 1:38 PM
Seen: 2284 times
Last updated: 3/16/15, 8:10 AM