Odoo Help


Google Calendar Sync - Error http 400

Tobias Frankl
on 12/22/14, 12:33 PM 3,957 views

In Odoo 8.0 I want to setup google calendar sync. I work with the tutorial through the developers console. Then with Google Calender open on my notebook I hit the "sync button" on calendar view. It asks for permission. That works. But when I hit the button next time - it should sync - it throws this error. It worked some time ago!

Could You give me a hint, where to search? Is it an nginx problem. Is it google api or just wrong handling. Tried for quite some time with different orders - phone or notebook, but the same error.

On the user page, calendar tab the the first three points are filled: "Refresh tokken", "User tokken", "tokken validity" - the last two are not: "Last syncro date"; "calendar ID"


Traceback (most recent call last): File "/opt/odoo/openerp/http.py", line 517, in _handle_exception return super(JsonRequest, self)._handle_exception(exception) File "/opt/odoo/openerp/http.py", line 535, in dispatch result = self._call_function(**self.params) File "/opt/odoo/openerp/http.py", line 294, in _call_function return checked_call(self.db, *args, **kwargs) File "/opt/odoo/openerp/service/model.py", line 113, in wrapper return f(dbname, *args, **kwargs) File "/opt/odoo/openerp/http.py", line 291, in checked_call return self.endpoint(*a, **kw) File "/opt/odoo/openerp/http.py", line 751, in __call__ return self.method(*args, **kw) File "/opt/odoo/openerp/http.py", line 387, in response_wrap response = f(*args, **kw) File "/opt/odoo/addons/google_calendar/controllers/main.py", line 43, in sync_data return gc_obj.synchronize_events(request.cr, request.uid, [], context=kw.get('local_context')) File "/opt/odoo/openerp/api.py", line 237, in wrapper return old_api(self, *args, **kwargs) File "/opt/odoo/addons/google_calendar/google_calendar.py", line 560, in synchronize_events new_ids += self.create_new_events(cr, uid, context=context) File "/opt/odoo/openerp/api.py", line 237, in wrapper return old_api(self, *args, **kwargs) File "/opt/odoo/addons/google_calendar/google_calendar.py", line 591, in create_new_events st, response, ask_time = self.create_an_event(cr, uid, att.event_id, context=context) File "/opt/odoo/openerp/api.py", line 237, in wrapper return old_api(self, *args, **kwargs) File "/opt/odoo/addons/google_calendar/google_calendar.py", line 258, in create_an_event return gs_pool._do_request(cr, uid, url, data_json, headers, type='POST', context=context) File "/opt/odoo/openerp/api.py", line 237, in wrapper return old_api(self, *args, **kwargs) File "/opt/odoo/addons/google_account/google_account.py", line 165, in _do_request raise e HTTPError: HTTP Error 400: Bad Request

Andre de Kock
On 1/21/16, 12:45 AM

Good day. Just had the same issue. Looked at the logs and found this:

Bad google request : {

"error": {

"errors": [


"domain": "global",

"reason": "invalid",

"message": "Invalid time zone definition for start time."



"domain": "global",

"reason": "invalid",

"message": "Invalid time zone definition for end time."



"code": 400,

"message": "Invalid time zone definition for start time."



I then went into my Odoo User and saw that my Timezone setting was blank. I then updated my Timezone and after that Google Calendar worked.

Eduardo Castellanos
On 2/7/15, 5:18 PM

I have same problem here, any idea how to solve it?

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

3 follower(s)


Asked: 12/22/14, 12:33 PM
Seen: 3957 times
Last updated: 1/29/16, 5:29 AM