Help

1

Google Calendar Sync: "Ending date cannot be set before starting date."

Avatar
James White

First sync with Odoo and everything appears fine but when I push the "Sync with Google" button, I get this error:

"Ending date cannot be set before starting date."

Unfortunately, the error gives me no idea of which item it is referring to.  I have viewed all appointments in list view to confirm that they all have a valid start vs end time (and they all have a positive duration) 

Is this something that I can look up in an error log somewhere? 

<gripe>

And WHY OH WHY would any developer not include some reference in his error?   An error saying "yer screwed mate" is not nearly as valuable as one that says "Record with start date 20171201 has an error of the following type..."

</gripe>

Avatar
Discard
3 Answers
0
Avatar
Marco Viviani
Best Answer

No James, you are not the only one.
This just happened to me too (same error message), suddenly, with no apparent reason, and I am searching desperately a way to fix.

I am using version 10 and I am experiencing date troubles.
As far as we tried to fix it, we suppose (just suppose) it is a date format problem, probably in the calendar.py file

# Convert the start date to saved timezone (or context tz) as it'll
# define the correct hour/day asked by the user to repeat for recurrence.

startdate = startdate.astimezone(timezone)  # transform "+hh:mm" timezone

rset1 = rrule.rrulestr(str(self.rrule), dtstart=startdate, forceset=True)

recurring_meetings = self.search([('recurrent_id', '=', self.id), '|', ('active', '=', False), ('active', '=', True)])

for meeting in recurring_meetings:
rset1._exdate.append(todate(meeting.recurrent_id_date))
return [d.astimezone(pytz.UTC) for d in rset1]

Did you experienced problems with recurring events?


6 Comments
Avatar
Discard
Avatar
James White
-

Hi Marco, it suddenly started working - I did nothing. Now I am on Odoo 11+e and everything works fine. I count on recurring appointments and so far have had no problems at all.

I strongly recommend upgrading to 11 - it is a good upgrade and solves some problems.

Avatar
Marco Viviani
-

Thank you for the quick reply!

I will try to upgrade, but I never did it.

Is it possible to keep the same PostgreSQL DB used with Odoo 10?

Avatar
James White
-

Yes... kind of. Go to https://upgrade.odoo.com and fill in the form. You will see instructions on how to EXPORT your existing database for upgrading. Once they are completed upgrading and testing for you, they will supply the UPGRADED database which you then import.

The first time you really want to read the instructions, but it goes pretty smoothly overall.

Avatar
Marco Viviani
-

Thank you James, we upgraded to version 12 and many bugs are over now :-)

anyway we still have a problem with recurrent events when the time switches from winter to summer time. Odoo shiftes the meeting hour of 1 and this causes a lot of problems...

May be you solved this one too?

Thank you very much

Avatar
Marco Viviani
-

...actually I just solved it. Just set the timezone for your User.

Avatar
James White
-

Very good. I was going to go into my settings to check timezones... but you beat me to it!

1
Avatar
Dimitri
Best Answer

I also have the "Ending date cannot be set before starting date." issue (Odoo 11 CE). The difference is that this calendar didn't complete a sync yet. It is a calendar which contains data over the past 10 years and I don't have a week to spare to check all these appointments...

A more useful error message would be appreciated. If someone has a quick solution, that would be great.


1 Comment
Avatar
Discard
Avatar
James White
-

Hi Dimitri, it is interesting that both of us are trying to import very OLD calendars. perhaps that is a hint.

Also interesting, the problem has recently solved itself and I have done nothing to make this happen. Is your calendar still having the problem?

1
Avatar
James White
Best Answer

I have burned two weeks trying to figure out if the problem is in Google or Odoo.  Since neither has any support at all - it's really just trial and error.

After exporting my .ics from Google, I have manually reviewed every appointment and NONE of them have an event that ends before it starts.  So now this just looks like an Odoo bug.

Am I the only person having this problem?

 


Avatar
Discard