Odoo Help


Google Calendar: Bad Request (400)

on 6/24/16, 4:58 PM 1,693 views


I have a strange behaviour with the Google Calendar in Odoo9. Until yesterday sync worked perfect. Suddenly, from one moment to another sync throws following error in the log: 

ERROR master openerp.addons.google_account.google_account: Bad google request : {
 "error": {
  "errors": [
    "domain": "calendar",
    "reason": "timeRangeEmpty",
    "message": "The specified time range is empty.",
    "locationType": "parameter",
    "location": "timeMax"
  "code": 400,
  "message": "The specified time range is empty."

This is quite strange. What is very interesting, it happens ONLY with my Admin Account. If I login as another user I can run the sync with further issues. 

The error message isn't clear enough for me.

It must be related to the user (admin) but where and how can I fix it?



You could check your timezone settings. The user one and the one in Google on you agenda have to be coherent.

Mind & Go, Mind And Go
on 1/31/18, 11:25 AM

Also have a look there : https://github.com/odoo/odoo/issues/12573 recommandations could also help

Mind & Go, Mind And Go
on 1/31/18, 11:26 AM
--Ahmed M.Elmubarak--

Ahmed M.Elmubarak
On 6/25/16, 3:20 AM


I think this issue related to the date range, e.g the date start is greater than the date end ...

So you can check your last activities searching for such input ...

Hope this could helps

I had a smiliar idea that it might be related to a wrong event. So I delete all my events from my user and error still exists. Other ideas?

on 6/25/16, 7:02 AM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)


Asked: 6/24/16, 4:58 PM
Seen: 1693 times
Last updated: 6/25/16, 3:20 AM