Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

German Translation of Swiss Chart of Accounts not working

By
Peter Baumann
on 9/21/15, 4:24 AM 1,121 views

Hi all,

Maybe someone can help me.

I installed Odoo 9 rc1 on a Virtual Machine with Ubuntu 14.04 successful. I used the nightly build of the *.deb package.

I could go through the initial setup wizard and everything is working well except the translation of the chart accounts for switzerland. It stays always in french, even when I loaded again german translation and overwrite all again.

I have seen that the german translation are there (/usr/lib/python2.7/dist-packages/openerp/addons/l10n_ch/i18n_extra/de.po) and is loaded:

openerp.addons.base.ir.ir_translation: module l10n_ch: loading extra translation file (de) for language de_DE
openerp.tools.translate: loading /usr/lib/python2.7/dist-packages/openerp/addons/l10n_ch/i18n_extra/de.po

So why is the translation not active?

I still have all the accounts in french text which is very complicated for us german speaking swiss to use.


Thanks for any help.

Peter

Is the language preference of your user set to german? As long as it is set to english, the french COA will be displayed because there is no english translation.

Ermin Trevisan
on 9/22/15, 2:36 AM

0 Peter Baumann On 9/22/15, 1:17 PM Hi Ermin, I forgot to mention that. Yes sure I changed to "German / Deutsch". Everything is in German but not the COA. I also loaded the Translation again with the overwrite option, doesn't help.

Peter Baumann
on 9/22/15, 7:17 AM

If I remember it correctly, the language preference set at the time of the installation of the accounting module is key (I used to install it with the admin user, which was of course set to english at installation time). In version 8.0 you can change that afterwards using this module: https://www.odoo.com/apps/modules/8.0/account_chart_update/ . Unfortunately I do not have an 9.0 instance ready at the moment to test it.

Ermin Trevisan
on 9/22/15, 9:13 AM

I also tried to create fresh database, installed NO module, changed user to german language, THEN installed Accounting Module but this also doesn't help...

Peter Baumann
on 9/22/15, 11:24 AM

So the important question is then howto reinstall COA after the initial installation of odoo. In version 8.0 this was possible to reselect a chart of accounts. I checked the manual but couldn't find any information how todo this in v9.0.

Peter Baumann
on 9/22/15, 11:30 AM

Accounting has undergone a major refactoring for v9. I will try it myself as soon as possible, but meanwhile you may have more luck with the mailing list: https://www.odoo.com/groups

Ermin Trevisan
on 9/22/15, 12:30 PM
0
Mauro Giudici
On 9/6/16, 3:22 AM

Hi any news on this? I have the same issue

Also all the Test for the Taxes are only in frech and I would like to have it in English (Mehrwertsteuer...)

0

Ermin Trevisan

--Ermin Trevisan--
3548
| 6 3 7
Walchwil, Switzerland
--Ermin Trevisan--


Ermin Trevisan
On 7/2/16, 2:14 AM

I can not reproduce this problem.  At my installation, the german translations work perfectly. Did you synchronize the terms properly?

0
Michael Freiermuth
On 7/1/16, 12:35 PM

As I had the same problem with account descriptions not beeing updated I've recognized that the table account_account was used for the chart.


Unfortunately the translation de.po files did not update the account translations in the charts.

/etc/init.d/odoo stop
 sudo  -u odoo /usr/bin/odoo.py --stop-after-init --load-language=de_DE -c /etc/odoo/openerp-server.conf -d odoo
/etc/init.d/odoo start


This didn't help either

DELETE FROM ir_translation WHERE lang='de_DE';
/etc/init.d/odoo stop
sudo -u odoo /usr/bin/odoo.py -d odoo -l de_DE --i18n-import=/usr/lib/python2.7/dist-packages/openerp/addons/account/i18n/de.po --i18n-overwrite
/etc/init.d/odoo start



THE "WORKAROUND"

What finally worked was a dirty workaround updating the account_account table with the values of the translations like the following with postgresql. Now the account texts are in German :)

UPDATE  odoo.public.account_account t1SET  name = t2.valueFROM  odoo.public.ir_translation t2  INNER JOIN odoo.public.ir_translation t3 USING (src)WHERE  t1.name = t2.src;



However this workaround might lead to problems sooner or later.
It would be interesting, if someone knews the right solution for this problem.

What do you mean with "Did you synchronize the terms properly"? (I'm using the community edition)

Michael Freiermuth
on 7/2/16, 11:19 AM

"Settings/Languages/Synchronize Terms"

Ermin Trevisan
on 7/4/16, 11:13 AM

I'm also using the community edition.

Ermin Trevisan
on 7/4/16, 11:14 AM

Ok, thank you for your help.

Today I did a fresh install Version 9.0c-20160705 (Community Edition) on Debian 8 like mentioned her

https://www.odoo.com/documentation/9.0/setup/install.html

As language I have "German (CH) / Deutsch (CH)"

Switzerland - Accounting l10n_ch is installed

I have synchronised the translations

When I click on Abrechnung / Kontenplan I can see the account name in French and the type in German

Same thing if I click to add a new journal entry (Buchungssatz) and select an account

Then i did change the language to "German / Deutsch" and now I can see the account name it in German

This behavior is not very logical as German CH is explicitly noted

Changing the language again to English leads to the same behavior like

"German (CH) / Deutsch (CH)" with account names in French and type in English

Michael Freiermuth
on 7/5/16, 5:01 AM

The problem is that there is no english translation of the chart of accounts. So if you are logged in with a user set to english language, you will see the french terms of the chart of accounts.

Ermin Trevisan
on 7/6/16, 2:46 AM

This is because the Swiss chart of accounts is provided by CamptoCamp and their primary language (source terms) is french.

Ermin Trevisan
on 7/6/16, 2:51 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 9/21/15, 4:24 AM
Seen: 1121 times
Last updated: 9/6/16, 3:22 AM