Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Generate Translation file

By
YannickB
on 10/24/14, 5:23 AM 901 views

Hello world,

I don't know why but since Odoo 8 I can't generate the .pot file to translate the module I develop. When I try to generate them, I select lang English, PO format and my module (same goes with official ones) and then the action goes on indefinitely.

I tried to test it on runbot, there is no problem there the file is generated in one second, so I think the a problem come from my dev platform. I am on Debian7, do you have any idea about what can cause this kind of problem so I can check it? Maybe missing python dependencies I don't know.

Regards,

Yannick.

Have you tried exporting the translation from the server command line?

Daniel Reis
on 10/24/14, 9:05 AM

Damn it I forgot it was possible. Unfortunately it doesn't solve the case: /path/to/odoo/odoo.py -c /path/to/config -d odoo_base --logfile=False --i18n-export=/path/to/file/account_wallet.pot Log ... openerp: writing translation file for new language to /path/to/file/account_wallet.pot ... But in the end the file generated is empty. I also tried with -l en_US, without result.

YannickB
on 10/24/14, 10:51 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 10/24/14, 5:23 AM
Seen: 901 times
Last updated: 3/16/15, 8:10 AM