Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

2

ftp server connection

By
selva
on 4/23/13, 9:29 AM 5,815 views

In knowledge module i clicked "shared repositories" to connect to ftp server in which i typed "ftp://localhost:8021" it just got connected but there was no window asking user name or password...And when i went to the browser and typed the same ftp address i got just two databases name getting displayed..when i click that i am nkt able to find the default folders which are available...plz help me..how should i do this

Have you created the filestore under openerp folder? Have you given acces to dbuser?

Tomás Pascual
on 5/2/13, 4:17 PM
2

Borni DHIFI

--Borni DHIFI--
5102
| 6 8 9
Tunis, Tunisia
--Borni DHIFI--

Techno Functional Consultant Odoo(OpenERP) 

http://www.linkedin.com/in/borni

Skype : dhifi.borni

Borni DHIFI
On 4/23/13, 12:25 PM

to configure ftp server go :

settings-->Configuration Wizards choose FTP Server Configuration

Indicate the network address on which your OpenERP server should be reachable for end-users. This depends on your network topology and configuration, and will only affect the links displayed to the users. The format is HOST:PORT and the default host (localhost) is only suitable for access from the server machine itself..(localhost:8021)

in knowledge menu proposed default ftp address. If you have problems connecting, then it may be a problem with the connection string.

default is:  ftp://admin@<your IP address>:8021/<your database name>
i e. ftp://admin@localhost:8021/my_company

try connecting using the string without the user name i.e.:

ftp://<your IP address>:8021/<your database name>
i e. ftp://localhost:8021/my_company

A pop-up will then appear for you to enter a user name and password. Ensure it's also an actual OpenERP user that exists in the database you are trying to connect to.

Please note that this solution may only work if you have at least one user logged into the database that you are trying to connect to.

when i type ftp://localhost:8021/demo in web browser, i get a pop up indicating user name and password...when i type that i am able to get in the root directory which displays the databases in which i have installed knowledge module.But when i try to enter that database it shows 550:Invalid database path...I am trying for a long time..but dont know where i went wrong.plz help me..I am new to openerp..

selva
on 4/24/13, 4:31 AM

connect to admin/admin in your database demo and in your browser ftp://admin@localhost:8021/demo . try to connect with another web browser .try to connect with a ftp client FileZilla for example and return to me. it should work.if it does not work you should check how you configured the server

Borni DHIFI
on 4/24/13, 6:32 AM

hey dude!! I tried with file zilla client...In which i typed the following HOST:localhost,USERNAME:admin,PASSWORD and port:8021.Here also i was able to see the listings of 2 directories name alone...But couldn enter that directory.Again it results in same error INVALID DATABASE PATH..plz help me out in this dude.. Am i making any silly mistake..Should i set path anywhere??

selva
on 4/24/13, 8:07 AM

and when i type in browser after entering credentials i get the usual web page error like "webpage is not available" temporariliy down or unavailable

selva
on 4/24/13, 8:08 AM

in settings/ technical/ parameters/ system parameters , add a new record: Key = ir_attachment.location Value = file:///filestore
and in openerp_serverr.config add ftp_server_host=localhost

Borni DHIFI
on 4/24/13, 8:17 AM

hey where do i find settings??Sorry i am new to openerp so i dont know..plz help- me dude..I COULD FIND PARAMETERS IN webclient under administration menu but that doesn have an option like that filestore or or system parameterts...thanks

selva
on 4/29/13, 5:45 AM

in settings>>Users choose your user and in tab Access Rights check Technical Features then refresh the page .menu settings/ technical/ parameters/ system parameters display .

Borni DHIFI
on 4/29/13, 5:57 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 4/23/13, 9:29 AM
Seen: 5815 times
Last updated: 3/16/15, 8:10 AM