Odoo Help


Fresh install of Odoo painfully slow

Robert Chadwick
on 5/22/15, 6:40 PM 2,130 views

I deployed Odoo on ESXi with a few Xeon processors, and it is very slow. Clicking most things have a 5 to 20 second delay, with some things taking longer. Is there some tuning I can do to make things better?

Hmm that is really very slow. What are the specs for RAM etc? Check your log to see if any errors /weird things pop up.

on 5/24/15, 9:41 AM

This slideshare gives some good info on fine tuning for performance: http://www.slideshare.net/openobject/performance2014-35689113 However, your results seems VERY slow. Is this a fresh database with minimal data or did you import a lot of data?

on 6/5/15, 11:21 AM

Hi ! Did you fix this ? I have a similar issue, running on vmware, no spikes on vsphere graphs.

on 9/28/15, 10:16 AM

Would be worth explaining how you installed it as there are many different ways to do this.

Elite Antennas Ltd., Julian Robbins
on 9/28/15, 12:12 PM
On 6/1/16, 1:33 AM

Hi, I use Bitnami VmWare version for several days. Virtual Machine has: 4 cores (1.6), 4GB Ram: it works as slow as Robert Ch. describes... Almost no data of course, just fresh as Bitnami provides.

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)


Asked: 5/22/15, 6:40 PM
Seen: 2130 times
Last updated: 6/1/16, 1:33 AM