Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

File size limit ? error

By
Martin Varela
on 1/27/14, 4:15 PM 3,877 views

I´m getting an error when I try to upload an attachment bigger than 25mb. The error is: Uncaught Error: [_.sprintf] huh?

Is there a limit of size on attachments? Why I´m getting this error?

I have configured to store files in the file system, not db.

Where are you trying to upload your files and how did you configure your system to store files on the Db?

GH Mediacloud, Grover Menacho
on 1/28/14, 8:51 AM
0
Martin Varela
On 1/28/14, 9:47 AM

I was trying in Spanish_UY, If I try in English it throws a Error Message saying that the maximum size of documents is 25MB. In file: ../web/static/source/js,
this.max_upload_size = 25 * 1024 * 1024; // 25Mb

Yes I know it but you are trying to upload to the database not to the filesystem

GH Mediacloud, Grover Menacho
on 1/28/14, 11:04 AM

I´m uploading in the file system. ir_attachment.location --> file://filestore I can see the attachments in the file system.

Martin Varela
on 1/29/14, 9:39 AM

This happens only with Documents uploaded through Knowledge module, not in attachment button.

Martin Varela
on 1/29/14, 9:42 AM

Martin, Did you figure out how to increase the limit. I am having the same problem and it appears to be a static value somewhere rather than a parameter we can change.

Mogens Nielsen
on 3/19/14, 4:18 PM

In file: ../addons/web/static/src/js/view_form.js (in my version of the file, line 4963) this.max_upload_size = 25 * 1024 * 1024; // 25Mo Change the number 25 for the size you want. If I put a number larger than aprox 200mb and try to attach a file of that size, the browser freezes. So, I´ve set it at 100 until I find out what´s the problem

Martin Varela
on 3/20/14, 1:35 PM

Martin, Thank you for responding. I actually found that same file myself (after a lot of digging) and it worked out. Mine was set to 250mb which so far has worked. Only report of a problem was from a phone upload where the upload failed with a cryptic message. Turned out it was due to screen turning off.

Mogens Nielsen
on 3/26/14, 2:30 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 1/27/14, 4:15 PM
Seen: 3877 times
Last updated: 3/16/15, 8:10 AM