Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

fields not saving problem

By
Qamar Soft
on 5/9/13, 8:49 AM 1,965 views

I inherit from stock.picking.out to add some fields

_inherit = 'stock.picking.out'

_columns = {
    'transp_name':fields.char('Chauffeur', size=25,store=True),
    'transp_tel':fields.char('Téléphone',size=14,store=True,),
    'transp_cin': fields.char('CIN Chauffeur', size=8,store=True, ),
    'transp_matricule': fields.char('Matricule Camion', size=64,store=True,  ),
}
_defaults = {
    'transp_name':'/',
    'transp_cin': '/',
    'transp_matricule': '/',
}

_order = "origin desc"

and the view :

     <record id="view_inherits" model="ir.ui.view">
        <field name="name">inherits.form</field>
        <field name="type">form</field>
        <field name="model">stock.picking.out</field>
        <field name="inherit_id" ref="stock.view_picking_out_form"/>
        <field name="arch" type="xml">
            <field name="invoice_state" position="after">
              <field name="transp_name"/>
              <field name="transp_cin"/>
              <field name="transp_tel"/>
              <field name="transp_matricule"/>
            </field>
        </field>
    </record>

when I clic in the Save button the transp_* became '' NOT SAVING !

Please copy the details of the error message ?

Borni DHIFI
on 5/9/13, 8:59 AM

there's no errors in log this is the addons http://www.mediafire.com/?bijzw7r78tx48gv

Qamar Soft
on 5/9/13, 9:10 AM

the module works without any problem!! and all transp_* are saved

Borni DHIFI
on 5/9/13, 9:19 AM

oups I will try in other DB

Qamar Soft
on 5/9/13, 9:21 AM

are you using Openerp 7 ? because it doesn't work in my server !!!!

Qamar Soft
on 5/9/13, 9:23 AM

yes .OpenERP7

Borni DHIFI
on 5/9/13, 9:39 AM

weird, My server is mad !!!!

Qamar Soft
on 5/9/13, 9:45 AM

probmel solved (y)

Qamar Soft
on 5/15/13, 11:38 AM
2

patrick

--patrick--
1958
| 5 4 7
Baarn, Netherlands
--patrick--
patrick
On 5/9/13, 10:11 AM

stock.picking.out is using the same table as stock.picking.in, namely the table stock.picking.

Did you add the same fields to the table/model stock.picking? I had issues when I added something to stock.picking, and not to stock.picking.out, that I could not save the data in my new field when using model stock.picking.out.

thanks for helping I solved the problem (y)

Qamar Soft
on 5/15/13, 11:38 AM
0
Qamar Soft
On 5/15/13, 11:36 AM

the problem was in the server version I downloaded an other version and it work well :)

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 5/9/13, 8:49 AM
Seen: 1965 times
Last updated: 3/16/15, 8:10 AM