Odoo Help

4

2
3 Answers
16
Avatar

Anabela Damas Portugal

--Anabela Damas--

796
| 6 7 7
Aveiro, Portugal
--Anabela Damas--
IT Consultant
Anabela Damas Portugal
5/13/13, 3:49 PM

Hi,

I don't know much but I've noticed that if I add a field without being inside a group the label isn't displayed, so I do like this if I don't mind to grouping the fields:

 <record model="ir.ui.view" id="notebook_form_view">
    <field name="name">notebook.form</field>
    <field name="model">notebook</field>
    <field name="type">form</field>
    <field name="arch" type="xml">
        <form string="Notebook" version = "v7">
        <sheet>
          <group>
            <field name="title"/>
            <field name="note"/>
            <field name="note_date"/>
         </group>
        </sheet>
        </form>
    </field>
</record>

or if I don't want the fields in a group I do like this:

 <record model="ir.ui.view" id="notebook_form_view">
    <field name="name">notebook.form</field>
    <field name="model">notebook</field>
    <field name="type">form</field>
    <field name="arch" type="xml">
        <form string="Notebook" version = "v7">
        <sheet>
            <label for="title" string="what you want to appear for title"/>
            <field name="title"/>
            <label for="note" string="what you want to appear for note"/>
            <field name="note"/>
            <label for="note_date" string="what you want to appear for note_date"/>
            <field name="note_date"/>
         </group>
        </sheet>
        </form>
    </field>
</record>

Hope this helps you =)

4 Comments
omprakash India
5/14/13, 2:37 AM

Hi Anabela Damas , Thanks for your immediate reply . Its working for me .

Andreas Maertens Germany
5/14/13, 3:48 AM

You should remove the <field name="type"> tag. That is depricated.

Versão Integral, Anabela Damas Portugal
5/14/13, 5:59 AM

You're welcome! If it works can you please accept the answer like a correct answer =)

omprakash India
5/15/13, 3:19 AM

Hi Andreas Maertens , Thanks for reply .

0
testopenerp India
2/17/14, 8:10 AM

Thanks for your answer Andreas Maertens. It is working.

1 Comment
sneha antony India
2/28/14, 7:33 AM

i tried all the above said things. Tried Anabela Damas's code(Both the codes),removed the <field name="type"> tag and deleted the "version" tag in the form field.But still the field labels are not displaying

0
Yao Singapore
7/8/13, 1:32 AM

I experienced the same issue. After deleting the "version" tag in the form field, the label is displayed as it should be.

<form string="Notebook" *version="v7*">

Ask a Question
Writer
Keep Informed
1 follower(s)
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register
Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now