Odoo Help

1

Fedora Core 18 startup script for V7.0 OpenERP needed

By
darren
on 2/25/13, 6:01 PM 3,424 views

Can anyone point me in the right direction of a startup script for FC18?

I followed this tutorial to install V7.0 on a clean FC18 server: smashingweb.info/install-open-erp-7-on-ubuntu-12-04-and-fedora-18/ and it works perfectly right up until the last instruction.. the init.d/ startup script :( I can start the service manually as per the instructions in the tutorial but can't use the script provided because it doesn't work or the stock openerp-server.init file because my file structure is different. The script in the tutorial looks like it was written for Debian! 5 Hours of server building and tutorial following and the author makes a foobar like that...Cheers!

Can anyone help?

What errors on output you have?

Anton
on 2/25/13, 6:11 PM

If I run the script which is included in the distribution I get this:

Starting OpenERP Server Daemon (openerp-server): [setsid: execvp failed: No such file or directory [ OK ]

And if I run using the script from the tutorial I get:

Starting openerp-server: ./openerp-server: line 46: start-stop-daemon: command not found openerp-server.

Hmmm.

darren
on 2/25/13, 6:14 PM

Ahh Ive corrected a path issue which has changed the error. Now using the stock .init file I get:

Starting OpenERP Server Daemon (openerp-server): [ OK ]

[root@openerp init.d]# Traceback (most recent call last):

File "/opt/openerp/server/openerp/cli/server.py", line 89, in setup_pid_file fd = open(config['pidfile'], 'w') IOError: [Errno 13] Permission denied: '/var/run/openerp/openerp-server.pid'

darren
on 2/25/13, 6:25 PM

sorted: I had root 755 permissions on /var/run/openerp. After changing it to the openerp user it worked perfectly

darren
on 2/25/13, 6:31 PM

Thanks for your help Anton, I've answered it myself, see below :)

darren
on 2/25/13, 6:39 PM
0
darren
On 2/25/13, 6:38 PM

Ok if you're building a clean FC18 server and want to run 7.0 you can follow this guide:

smashingweb.info/install-open-erp-7-on-ubuntu-12-04-and-fedora-18/

but dont download the startup script in section 7, its wrong, very wrong, just copy and paste the /opt/openerp/server/install/openerp-server.init to /etc/init.d/ and rename it openerp-server.

Open your new openerp-server file using your favorite editor and on line 63 change the text to this:

"/usr/bin/setsid /opt/openerp/server/openerp-server \

Other than that there are no changes to make to the tutorial, Im up and running.

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

0 follower(s)

Stats

Asked: 2/25/13, 6:01 PM
Seen: 3424 times
Last updated: 3/16/15, 8:10 AM