Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Exporting many records -- browser just spins forever, no errors in log

By
Douglas Muller
on 4/16/14, 3:52 PM 784 views

I've run into this problem a few times: when trying to export many records, the export process causes the browser just to spin, never finishing (despite the cute notes to go get coffee, etc.). I've waited in vain up to 60 minutes.

Nothing strange showing up in the logs. Not sure how else to diagnose. Is there a more verbose log than the standard openerp-server.log?

I've experienced this problem with accounting records, product records, and now in the Configuration > Taxes list view screen. I'm trying to export 2100 records. Worked easily for batches of 500--then I realized the result set order was changing after I updated the records and re-imported, making it impossible to track which I had updated and which I hadn't without drilling into records one by one. So I tried exporting all records to find which needed updating, and now the most I seem to be able to export successfully is one record.

I am able to perform exports from other screens--this one just seems strangely damaged and non-functional.

Any tips or ideas?

Thanks for any advice.

Doug

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 4/16/14, 3:52 PM
Seen: 784 times
Last updated: 3/16/15, 8:10 AM