Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

ESC/POS Hardware Driver causes XmlHttpRequestError!

By
John Baldwin
on 2/9/15, 5:22 AM 1,760 views

I've tried to install this with and without NGINX as a reverse proxy. I meet the prequisites, but everytime I try to install odoo terminates and does a core dump. What am I doing wrong?

! have installed PyUSB, Python QR Code and some the server log said I needed "pip install jcconv". I thought the error was something in NGINX so I configured a new server and installed a nightly package and tried to install the driver at MyIP:8069 with zero secruity and it still fails. This is what my log says:

INFO mydb openerp.modules.module: module hw_proxy: creating or updating database tables

or I get this the nothing:

2015-02-09 10:19:38,258 17623 INFO mydb openerp.modules.loading: loading 1 modules...
2015-02-09 10:19:38,391 17623 INFO mydb openerp.modules.loading: 1 modules loaded in 0.13s, 0 queries
2015-02-09 10:19:38,496 17623 INFO mydb openerp.modules.loading: loading 17 modules...
2015-02-09 10:19:38,531 17623 INFO mydb openerp.modules.loading: 17 modules loaded in 0.03s, 0 queries
2015-02-09 10:19:38,534 17623 INFO mydb openerp.modules.loading: loading 18 modules...

Any Clues? 

1
Amine
On 2/10/15, 6:12 PM

Salamu Alaikum,

It has to do with the libusb (pyusb) software used on your OS, I'm still strugling with it, but i hope i'm close to it Inshallah.

Try to use another version of pyusb

here is the Solution (Hope it will work for you either Inshallah):

pip uninstall pyusb

pip install pyusb==1.0.0a2

If its ok mark it as answered, so that people can get benefit from it

http://www.sayoo.org Say Infinite possibilities

Although this solution has been accepted, I am unable to get it to work. I have installed 2 dependancies, namely pyusb-1.0.0b2 and qrcode-5.1 I don't get an error about imports anymore when I try to install hw_posesc, but the system just exits, throwing an xmlhttprequesterror. I have also tried to install the alpha release you posted, but this didn't change a thing. I also tried installing the jcconv the OP mentioned, but this is to translate chinese character, so I thought this wouldn't do too much. As I thought, this didn't solve my problem. Any more suggestions? Installing through command_line won't work either. Just does nothing (-i hw_escpos)

Cats&Dogs bvba, SonnyV
on 8/25/15, 6:03 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 2/9/15, 5:22 AM
Seen: 1760 times
Last updated: 8/25/15, 7:03 AM