Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

Error while updating Modules. [Closed]

By
turalo
on 2/10/13, 4:16 PM 1,697 views

The Question has been closed for reason: not in english

by
Yannick Vaucher
on 03/08/2013 12:09:55

Hi guys, I have clicked on update Modules / update this is what I get :

OpenERP Server Error

Client Traceback (most recent call last):
  File "/home/odoo/source/web/addons/web/http.py", line 195, in dispatch
    response["result"] = method(self, **self.params)
  File "/home/odoo/source/openerp_custom_7.0/loempia/controllers/embed.py", line 40, in download_urls
  File "/home/odoo/source/web/addons/web/session.py", line 43, in proxy
    result = self.proxy.execute_kw(self.session._db, self.session._uid, self.session._password, self.model, method, args, kw)
  File "/home/odoo/source/web/addons/web/session.py", line 31, in proxy_method
    result = self.session.send(self.service_name, method, *args)
  File "/home/odoo/source/web/addons/web/session.py", line 104, in send
    raise xmlrpclib.Fault(openerp.tools.ustr(e), formatted_info)


Server Traceback (most recent call last):
  File "/home/odoo/source/web/addons/web/session.py", line 90, in send
    return openerp.netsvc.dispatch_rpc(service_name, method, args)
  File "/home/odoo/source/server/openerp/netsvc.py", line 289, in dispatch_rpc
    start_rss, start_vms = psutil.Process(os.getpid()).get_memory_info()
  File "/home/odoo/source/server/openerp/service/web_services.py", line 614, in dispatch
    res = fn(db, uid, *params)
  File "/home/odoo/source/server/openerp/osv/osv.py", line 169, in execute_kw
    return self.execute(db, uid, obj, method, *args, **kw or {})
  File "/home/odoo/source/server/openerp/osv/osv.py", line 123, in wrapper
    return f(self, dbname, *args, **kwargs)
  File "/home/odoo/source/server/openerp/osv/osv.py", line 179, in execute
    res = self.execute_cr(cr, uid, obj, method, *args, **kw)
  File "/home/odoo/source/server/openerp/osv/osv.py", line 166, in execute_cr
    return getattr(object, method)(cr, uid, *args, **kw)
  File "/home/odoo/source/openerp_custom_7.0/loempia/loempia2.py", line 508, in compute_modules_to_install
    i = 1
AssertionError: Unknown modules requested: [u'']

Any idea what it is ?

thanks in advance.

1
turalo
On 2/10/13, 6:36 PM

Alright, problem solved. This error has something to do with the demo items.

After I removed the DB, then recreated a new one but this time empty. Without demo content, everything works fine.

Thanks for help.

0

There is not update available. So no need to click on this button.

The problem come from the apps server. I will fix it tomorrow. Thank for the report.

Ok, it's fixed and deployed :)

Christophe Simonis (chs)
on 2/10/13, 6:23 PM
0
Gustavo
On 2/10/13, 4:21 PM

Looks like there are problems with the loempia module. Try removing it, restarting the server and clicking update to see if the problem does not occur again,

Hi, can you be more specific? where can I find this module? cause this is just fresh install with empty DB. I had a demo install with al modules enabled, I had same error there. where can I find this loempia module ?

turalo
on 2/10/13, 4:56 PM

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 2/10/13, 4:16 PM
Seen: 1697 times
Last updated: 3/16/15, 8:10 AM