Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


error while install aeroo on Openerp 7

on 5/22/13, 4:28 PM 2,493 views

i used this steps to install aeroo

1- install aeroo using bzr using this command

bzr branch lp:aeroo

2- copy the folders from the downloaded folder and paste it in addons in my workspace

3- update all my database using

python workspace/actel-v2/openerp-server -d [my datatbase] --update=all

and i find it in the modules but when i install it i find this error

2013-05-22 17:04:09,201 20694 ERROR reports openerp.addons.base.ir.ir_ui_view: Can't render view for model: ir.actions.report.xml

Traceback (most recent call last):

File "/home/x/workspace/actel-v2/openerp/addons/base/ir/ir_ui_view.py", line 125, in _check_render_view fvg = self.pool.get(view.model).fields_view_get(cr, uid, view_id=view.id, view_type=view.type, context=context)

File "/home/x/workspace/actel-v2/openerp/addons/report_aeroo/report_xml.py", line 387, in fields_view_get transfer_modifiers_to_node(modifiers, deferred_node[0])

IndexError: list index out of range

2013-05-22 17:04:09,206 20694 ERROR reports openerp.tools.convert: Parse error in /home/x/workspace/actel-v2/openerp/addons/report_aeroo/report_view.xml:96:

<record id="act_aeroo_report_xml_view_tree" model="ir.ui.view">

        <field name="name">ir.actions.report.xml.tree</field>
        <field name="model">ir.actions.report.xml</field>
        <field name="arch" type="xml">
            <tree string="Report xml">
                <field name="name"/>
                <field name="model"/>
                <field name="report_name"/>
                <field name="in_format"/>
                <field name="out_format"/>
                <field name="tml_source"/>

Traceback (most recent call last):
File "/home/x/workspace/actel-v2/openerp/tools/convert.py", line 847, in parse self._tagsrec.tag File "/home/x/workspace/actel-v2/openerp/tools/convert.py", line 814, in _tag_record id = self.pool.get('ir.model.data')._update(cr, self.uid, rec_model, self.module, res, rec_id or False, not self.isnoupdate(data_node), noupdate=self.isnoupdate(data_node), mode=self.mode, context=rec_context ) File "/home/x/workspace/actel-v2/openerp/addons/base/ir/ir_model.py", line 956, in _update res_id = model_obj.create(cr, uid, values, context=context) File "/home/x/workspace/actel-v2/openerp/addons/base/ir/ir_ui_view.py", line 102, in create return super(osv.osv, self).create(cr, uid, values, context)

File "/home/x/workspace/actel-v2/openerp/osv/orm.py", line 4473, in create self._validate(cr, user, [id_new], context) File "/home/x/workspace/actel-v2/openerp/osv/orm.py", line 1546, in _validate raise except_orm('ValidateError', '\n'.join(error_msgs)) except_orm: ('ValidateError', u'Error occurred while validating the field(s) arch: Invalid XML for View Architecture!')

2013-05-22 17:04:09,209 20694 ERROR reports openerp.netsvc: ValidateError Error occurred while validating the field(s) arch: Invalid XML for View Architecture! Traceback (most recent call last): File "/home/x/workspace/actel-v2/openerp/netsvc.py", line 289, in dispatch_rpc result = ExportService.getService(service_name).dispatch(method, params)

File "/home/x/workspace/actel-v2/openerp/service/web_services.py", line 614, in dispatch res = fn(db, uid, *params)

File "/home/x/workspace/actel-v2/openerp/osv/osv.py", line 169, in execute_kw return self.execute(db, uid, obj, method, args, *kw or {})

File "/home/x/workspace/actel-v2/openerp/osv/osv.py", line 125, in wrapper raise except_osv(inst.name, inst.value)

except_osv: ('ValidateError', u'Error occurred while validating the field(s) arch: Invalid XML for View Architecture!')

so what's wrong??


Mohammad Alhashash

--Mohammad Alhashash--
| 5 5 8
Giza, Egypt
--Mohammad Alhashash--


Mohammad Alhashash
On 5/23/13, 6:39 AM

Make sure you have the latest version of OpenERP server package. It is apparently a bug in an intermediate 7.0 release.

thx Mohamed ... could u give me a link and what about my modifications?.. will i lose it? could you give me ur contact (FB or Gmail)

on 5/23/13, 7:00 AM

You should download the latest version from launchpad. (ex. bzr co --lightweght lp:openobject-server/7.0 server), make sure you update the openobject-addons and openerp-web too. Or you can download packages from OpenERP Runbot.

Mohammad Alhashash
on 5/23/13, 9:46 AM

sorry mohamed but when i install report_aeroo_ooo it couldn't configure succefully with libreoffice

on 5/29/13, 10:50 AM

You need to have LiberOffice running with the same version of python as OpenERP as report_aeroo_ooo needs to import PyUno package which bundled with OpenOffice and not available standalone for Windows. you can use OpenOffice 3 and use Python 2.6 to Run OpenERP. LibeOffice uses Python 3 on Windows. For Linux, make sure you are using system bundled Python and OpenOffice/LiberOffice.

Mohammad Alhashash
on 5/29/13, 4:36 PM

I already use Ubuntu 12.04, LibreOffice, Python 2.7, latest version from OpenERP

could u give me details or steps to solve this problem?

on 5/30/13, 6:18 AM

Make sure you have pyuno installed. It may be called libreoffice-pyuno.

Mohammad Alhashash
on 5/30/13, 8:45 AM

thanks Mohammed i finally solve all of it really thank you

on 6/2/13, 7:26 AM

hi , i have the same error and i am using openERP v7 running on ubuntu 12.04 and i have openoffice and install python packages but still have the same error :Invalid XML for View Architecture!') , could you help me how you did solve this error ?

Ahmed elbarbary
on 2/24/15, 2:21 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)


Asked: 5/22/13, 4:28 PM
Seen: 2493 times
Last updated: 3/16/15, 8:10 AM