Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Error while adding user

By
Marwa Ayari
on 4/13/14, 10:12 PM 1,282 views

Hi everyone, I'm new to OpenERP. After finishing installing it and trying to start working on it I got these errors:

Client Traceback (most recent call last): File "/opt/openerp/openerp-7.0-20140412-231254/openerp/addons/web/http.py", line 204, in dispatch response["result"] = method(self, *self.params) File "/opt/openerp/openerp-7.0-20140412-231254/openerp/addons/web/controllers/main.py", line 1128, in call_kw return self._call_kw(req, model, method, args, kwargs) File "/opt/openerp/openerp-7.0-20140412-231254/openerp/addons/web/controllers/main.py", line 1120, in _call_kw return getattr(req.session.model(model), method)(args, **kwargs) File "/opt/openerp/openerp-7.0-20140412-231254/openerp/addons/web/session.py", line 42, in proxy result = self.proxy.execute_kw(self.session._db, self.session._uid, self.session._password, self.model, method, args, kw) File "/opt/openerp/openerp-7.0-20140412-231254/openerp/addons/web/session.py", line 30, in proxy_method result = self.session.send(self.service_name, method, *args) File "/opt/openerp/openerp-7.0-20140412-231254/openerp/addons/web/session.py", line 103, in send raise xmlrpclib.Fault(openerp.tools.ustr(e), formatted_info)

Server Traceback (most recent call last): File "/opt/openerp/openerp-7.0-20140412-231254/openerp/addons/web/session.py", line 89, in send return openerp.netsvc.dispatch_rpc(service_name, method, args) File "/opt/openerp/openerp-7.0-20140412-231254/openerp/netsvc.py", line 296, in dispatch_rpc result = ExportService.getService(service_name).dispatch(method, params) File "/opt/openerp/openerp-7.0-20140412-231254/openerp/service/web_services.py", line 626, in dispatch res = fn(db, uid, params) File "/opt/openerp/openerp-7.0-20140412-231254/openerp/osv/osv.py", line 190, in execute_kw return self.execute(db, uid, obj, method, *args, *kw or {}) File "/opt/openerp/openerp-7.0-20140412-231254/openerp/osv/osv.py", line 132, in wrapper return f(self, dbname, args, *kwargs) File "/opt/openerp/openerp-7.0-20140412-231254/openerp/osv/osv.py", line 199, in execute res = self.execute_cr(cr, uid, obj, method, args, *kw) File "/opt/openerp/openerp-7.0-20140412-231254/openerp/osv/osv.py", line 187, in execute_cr return getattr(object, method)(cr, uid, args, *kw) File "/opt/openerp/openerp-7.0-20140412-231254/openerp/addons/base/res/res_users.py", line 800, in default_get values = super(users_view, self).default_get(cr, uid, fields1, context) File "/opt/openerp/openerp-7.0-20140412-231254/openerp/osv/orm.py", line 1599, in default_get defaults[f] = self._defaultsf File "/opt/openerp/openerp-7.0-20140412-231254/openerp/addons/base/res/res_users.py", line 250, in <lambda> 'image': lambda self, cr, uid, ctx={}: self.pool.get('res.partner')._get_default_image(cr, uid, False, ctx, colorize=True), File "/opt/openerp/openerp-7.0-20140412-231254/openerp/addons/base/res/res_partner.py", line 306, in _get_default_image image = tools.image_colorize(image) File "/opt/openerp/openerp-7.0-20140412-231254/openerp/tools/image.py", line 134, in image_colorize image.paste(original, mask=original) File "/usr/lib/python2.7/dist-packages/PIL/Image.py", line 1112, in paste im.load() File "/usr/lib/python2.7/dist-packages/PIL/ImageFile.py", line 192, in load d = Image._getdecoder(self.mode, d, a, self.decoderconfig) File "/usr/lib/python2.7/dist-packages/PIL/Image.py", line 381, in _getdecoder raise IOError("decoder %s not available" % decoder_name) IOError: decoder zip not available

Did you uploaded an image for the user ? if yes, which, image file format, and the size of the file ?

Med Said BARA
on 4/13/14, 10:46 PM
0

Med Said BARA

--Med Said BARA--
2664
| 5 5 7
Algeria
--Med Said BARA--
Med Said BARA
On 4/13/14, 10:58 PM

Try to follow the instruction here

And also read this

Thanks for your response. Actually I did not upload an image for the user, all I did was hit the button "Create" on the web interface. I followed the instructions on the first link and I've got another error:

IOError: cannot identify image file

Marwa Ayari
on 4/14/14, 5:00 AM
Med Said BARA
on 4/14/14, 8:33 AM

You are using an old (or wrong - it seems like you are using an old version of PILLOW) version of PIL. Download it here http://effbot.org/downloads/Imaging-1.1.7.tar.gz

Med Said BARA
on 4/14/14, 9:09 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 4/13/14, 10:12 PM
Seen: 1282 times
Last updated: 3/16/15, 8:10 AM