Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Error when "Generating Accounting Entries" on HR-> Expense [Closed]

By
Abner Galeno Jr.
on 3/23/13, 3:39 PM 1,554 views

The Question has been closed for reason: off-topic or not relevant

by
Fabien Pinckaers (fp)
on 03/24/2013 07:51:39

When I'm trying the demo out, I can easily complete the "Generate Accounting Entries" operation when finishing the Expenses under Human Resource.

When I try to create my own "My Sample" non-demo Database/Company, clicking the button "Generate Accounting Entries" results to an error:

 OpenERP Server Error
Client Traceback (most recent call last):
  File "C:\Program Files\OpenERP 7.0-20130323-002356\Server\server\openerp\addons\web\http.py", line 203, in dispatch
  File "C:\Program Files\OpenERP 7.0-20130323-002356\Server\server\openerp\addons\web\controllers\main.py", line 1140, in exec_workflow
  File "C:\Program Files\OpenERP 7.0-20130323-002356\Server\server\openerp\addons\web\session.py", line 148, in exec_workflow
  File "C:\Program Files\OpenERP 7.0-20130323-002356\Server\server\openerp\addons\web\session.py", line 31, in proxy_method
  File "C:\Program Files\OpenERP 7.0-20130323-002356\Server\server\openerp\addons\web\session.py", line 104, in send

  ..... more traceback in between...

  File "C:\Program Files\OpenERP 7.0-20130323-002356\Server\server\.\openerp\osv\orm.py", line 3604, in read
  File "C:\Program Files\OpenERP 7.0-20130323-002356\Server\server\.\openerp\osv\orm.py", line 3656, in _read_flat
  File "C:\Program Files\OpenERP 7.0-20130323-002356\Server\server\.\openerp\sql_db.py", line 161, in wrapper
  File "C:\Program Files\OpenERP 7.0-20130323-002356\Server\server\.\openerp\sql_db.py", line 226, in execute
ProgrammingError: operator does not exist: integer = boolean
LINE 1: ...d FROM "account_account" WHERE account_account.id IN (false)...
                                                         ^

HINT:  No operator matches the given name and argument type(s). You might need to add explicit type casts.

The way I understand the error, it seems I failed specify an Account Code. I have no idea what is missing, however, because the settings on the "Demo" database and on the "My Sample" are the same(I checked almost all settings).

The field "Force Journal" are both blank. The product entered on both "demo" and "my sample" database/company is a new inventory item named "PC Mouse". The "Employee" and the "Validation By" fields are all filled up with the user "Administrator". The Administrator "Home Address" was also specified on both "demo" and "My Sample" database/company.

Does anyone have an idea what could be the reason for the error? I just installed the latest nightly build and it's still the same... March 16 nightly build gave me a human-readable error but I failed to take a note, but it's also saying something related to an account ..

You should report bugs on launchpad, not here. (when there is a traceback displayed in the client side, it's always qualifiied as a bug)

Fabien Pinckaers (fp)
on 3/24/13, 7:52 AM

Noted. Thanks. I got to find the human readable error I once saw. This could be just an issue with my accounting setup/settings.

Abner Galeno Jr.
on 3/24/13, 10:30 PM

for your information, this should be fixed in revision 8948 of addons (v7). Thanks anymway for reporting, but next time it would be better to do so in launchpad (https://bugs.launchpad.net/openobject-addons) because it is dedicated to that ;-)

Quentin De Paoli (qdp)
on 3/27/13, 12:52 PM

I'll use launchpad next time :) Not sure if this should be a separate question: Why don't I see anything under the changelog tab when checking for module description? Should I [ideally] be able to find the revision number there? Also when downloading from nightly.openerp.com, the nightly builds seems to have no release notes. I have no way to find what add-on fixes are included in the binary releases...

Abner Galeno Jr.
on 3/28/13, 11:16 AM

I just checked nightly build "openerp-allinone-setup-7.0-20130331-001649.exe" and it no longer has that bug. Yay! Thanks :)

Abner Galeno Jr.
on 3/31/13, 12:27 PM

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 3/23/13, 3:39 PM
Seen: 1554 times
Last updated: 3/16/15, 8:10 AM