Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

Error <The report "report.stock.picking.list" already exists!>

By
Saïd Assar
on 7/4/13, 5:32 PM 3,592 views

I am trying to install v7.0 for the first time on a Win7 machine. Previously was installed a v.5.1.14 which has been desinstalled, and I use a new folder for the new version.

The installation went perfect, and I log admin, but when I try to install a new module, I get systematically the same long error message which ends with the sentence <the report="" "report.stock.picking.list"="" already="" exists!="">. I have tried many different modules, and get the same error, except the module Employee Directory which installs without error.

I am very annoyed because I can't use OpenERP. I am a confirmed user, I have been teaching it since version 5.0 four years ago. I like very much this software, but there is a tendency to push new versions of the software to the market before they are really ready. And I am surprised to not have the possibility to download previous versions.

Thank you for you help.

0
MartinHerweg
On 10/15/13, 3:55 PM

i did this to fix the problem:

cd /usr/lib/pymodules/python2.7
chmod 000 openerp
/etc/init.d/openerp-server-7.0 restart

/usr/lib/pymodules/python2.7/openerp is my openerp 6 folder.

I have openerp 7 installed in the /opt folder. It has it's own startscript.

Thank you for the suggestion. However, I am installing OperERP on a WIn7 machine, and I can't find these folders ... Up till now, I am experiencing the same problem, I guess it has a simple solution as few people seem concerned.

I would appreciate your help folks as I need to have this installation ready in some weeks for teaching purposes.

Saïd Assar
on 11/13/13, 5:14 AM

On Win7, it will be in: 1- If you used the All in One Installer: C:\Program Files\OpenERP 7.0-xxxxxxxxxxxxx\Server\server\openerp\ 2- If you used setup.py to build OpenERP: C:\Program Files\Python27\Lib\site-packages\openerp-7.0_xxxxxxxxxxxxx-py2.7.egg\openerp

Right click on the folder > Properties > Untick 'Read Only' option.

Mustafa Rawi
on 11/27/13, 7:57 AM
0

patrick

--patrick--
1958
| 5 4 7
Baarn, Netherlands
--patrick--
patrick
On 7/5/13, 8:52 AM

After uninstalling V5 and installing V7, did you use the same database as before? Or did you start a new database?

What happens when you create a new database, do you get the same error?

Are there any custom made modules you use? Sometimes those modules have their own reports, or override / delete original reports.

I have the same bug. fresh database, no custom modules

MartinHerweg
on 10/15/13, 3:38 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 7/4/13, 5:32 PM
Seen: 3592 times
Last updated: 3/16/15, 8:10 AM