Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Error printing quotation report in trunk. Can anyone confirm this ?

By
Christian Parent
on 4/15/14, 6:09 PM 1,617 views

Every time I try to print a quotation, I receive an error. I have submitted a bug report on launchpad. Could anyone confirm it is indeed a problem with openerp v8 ?

1

Ray Carnes

--Ray Carnes--
15717
| 9 7 9
Greater Los Angeles, United States
--Ray Carnes--

Senior Odoo Analyst

OpenERP 6.1, 7.0 and Odoo 8.0, 9.0 (Since 2012)

Completed Functional and Technical Training.

Major Skills:

  • Needs Discovery and Requirements Analysis;

  • Function and Technical Specifications;

  • Project Planning;

  • Prototyping and Proof of concepts;

  • Data migration;

  • Configuration & Customization (UI and modules);

  • Integration - data, business logic and service levels;

  • Training and Knowledge transfer;

  • Go Live support;

  • Help desk;

  • Version Migration.

I have over 20 years of experience empowering and enabling users with enterprise information systems that make a real and measurable difference in their ability to proactively manage their businesses and organizations. 

Ray Carnes
On 4/15/14, 11:56 PM

I can confirm it is NOT a problem.

I tested with the latest build [trunk-31343 - server (5185); addons (9343); web (3975)].

I can print a:

Sales -> Sales -> Quotation

and a

Purchases -> Purchase -> Quotation

using both the Print button and the Print dropdown.

TIPS:
(1) If you want to increase the chances someone can help you, expand "an error" into something meaningful or ideally, post the traceback message.

(2) Since there are several(!) bug reports on launchpad, link to your report.

I still cannot post links. And the error trace is rather long but, in my bug report. Lets See if this works. hxxps://bugs.launchpad.net/purchase-report/+bug/1306047

Christian Parent
on 4/16/14, 1:03 AM

I am using Version 8.0dev-20140407-103631, tried it again this morning, create a new "purchase" Request for Quotation:

  • Supplier: Digikey
  • Supplier reference: (empty and with N/A)
  • Pricelist: (Default Purchase Pricelist CAD)
  • Currency: CAD
  • Date: Auto Fill
  • Destination Warehouse: (My wharehouse)
  • Added an item to buy (Everything auto-filled in except analytic account left blank)

Incoming Shipments & Invoices left at default.

Saved it all. (Follow below)

Christian Parent
on 4/16/14, 11:53 AM

Tried send by email:

File "/opt/openerp/server/openerp/addons/base/ir/ir_qweb.py", line 295, in render_element raise_qweb_exception(message="Could not render element %r" % element.nodeName, node=element, template=template)

File "/opt/openerp/server/openerp/addons/base/ir/ir_qweb.py", line 290, in render_element g_inner.append(self.render_node(current_node, qwebcontext))

File "/opt/openerp/server/openerp/addons/base/ir/ir_qweb.py", line 271, in render_node result = self._render_tagt_render

Christian Parent
on 4/16/14, 11:55 AM

File "/opt/openerp/server/openerp/addons/base/ir/ir_qweb.py", line 409, in render_tag_field column = record._model._all_columns[field_name].column QWebException: 'NoneType' object has no attribute '_model'

And when I try Print button OR print Request for Quotation in drop down, I get a popup:

Uncaught SyntaxError: Unexpected end of input http://xxx.xxx.xxx.xx:xx/web#id=15&view_type=form&model=purchase.order&menu_id=346&action=406:0

and the server spit out the same trace.

Christian Parent
on 4/16/14, 11:55 AM
0
Christian Parent
On 4/16/14, 12:19 PM

I finaly found out. There are quotation / order reports for repair and sales but, only Purchase Order report !

My bad, it does exist, simply under a different naming... Sale and Repair Quotation/Orders are the same pdf :

Quotation / Order mrp.repair ir.actions.report.xml mrp_repair.report_mrprepairorder PDF Quotation / Order sale.order ir.actions.report.xml sale.report_saleorder PDF

But the Purchase one are on 2 different reports:

Purchase Order purchase.order ir.actions.report.xml purchase.report_purchaseorder PDF Request for Quotation purchase.order ir.actions.report.xml purchase.report_purchasequotation PDF

Christian Parent
on 4/16/14, 12:46 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 4/15/14, 6:09 PM
Seen: 1617 times
Last updated: 3/16/15, 8:10 AM