Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Error on updating Quantity on Hand

Matthew Fournier
on 8/1/13, 4:33 PM 2,462 views

Every time I try to edit a product's quantity from the product menu (clicking "update" in the inventory tab) I get this error.

Client Traceback (most recent call last): File "/opt/openerp/v7/web/addons/web/http.py", line 204, in dispatch response["result"] = method(self, *self.params) File "/opt/openerp/v7/web/addons/web/controllers/main.py", line 1128, in call_kw return self._call_kw(req, model, method, args, kwargs) File "/opt/openerp/v7/web/addons/web/controllers/main.py", line 1120, in _call_kw return getattr(req.session.model(model), method)(args, **kwargs) File "/opt/openerp/v7/web/addons/web/session.py", line 42, in proxy result = self.proxy.execute_kw(self.session._db, self.session._uid, self.session._password, self.model, method, args, kw) File "/opt/openerp/v7/web/addons/web/session.py", line 30, in proxy_method result = self.session.send(self.service_name, method, *args) File "/opt/openerp/v7/web/addons/web/session.py", line 103, in send raise xmlrpclib.Fault(openerp.tools.ustr(e), formatted_info)

Server Traceback (most recent call last): File "/opt/openerp/v7/web/addons/web/session.py", line 89, in send return openerp.netsvc.dispatch_rpc(service_name, method, args) File "/opt/openerp/v7/server/openerp/netsvc.py", line 292, in dispatch_rpc result = ExportService.getService(service_name).dispatch(method, params) File "/opt/openerp/v7/server/openerp/service/web_services.py", line 626, in dispatch res = fn(db, uid, params) File "/opt/openerp/v7/server/openerp/osv/osv.py", line 188, in execute_kw return self.execute(db, uid, obj, method, *args, *kw or {}) File "/opt/openerp/v7/server/openerp/osv/osv.py", line 131, in wrapper return f(self, dbname, args, *kwargs) File "/opt/openerp/v7/server/openerp/osv/osv.py", line 197, in execute res = self.execute_cr(cr, uid, obj, method, args, *kw) File "/opt/openerp/v7/server/openerp/osv/osv.py", line 185, in execute_cr return getattr(object, method)(cr, uid, args, *kw) File "/opt/openerp/v7/addons/stock/wizard/stock_change_product_qty.py", line 70, in default_get res.update({'location_id': location_id and location_id.id or False}) AttributeError: 'int' object has no attribute 'id'

I did not get this error before, and I have not edited any code or database that would change they way this feature performs. I've attempted to create an entirely new OpenERP server, and continue to get the error.

Please try with latest code. It's not giving any error.

Hiral Patel (hip)
on 8/2/13, 3:22 AM

I just set up this OpenERP install yesterday. The one I've had for a month or so is giving me no problems, but the new code is.

Matthew Fournier
on 8/2/13, 2:28 PM

Hey Matthew, have you solved this problem? I'm getting the same error.... cheers from Brazil

on 8/30/13, 8:54 PM

Are you using the openlabs magento connector?

on 8/30/13, 8:55 PM

Anyone a solution for this error?

on 2/24/14, 3:04 PM

I wound up wiping the whole installation and re-installing from scratch, and it fixed it. I'm afraid I don't know any more information, I never did find out what caused it.

Matthew Fournier
on 2/28/14, 7:08 PM
On 8/30/13, 8:54 PM

Hey Matthew, have you solved this problem? I'm getting the same error.... cheers from Brazil

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)


Asked: 8/1/13, 4:33 PM
Seen: 2462 times
Last updated: 3/16/15, 8:10 AM