Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Error in kanban view, invalid xml?

By
Andrea Dalseno
on 5/6/14, 8:03 PM 1,120 views

Hi, I tried to set up a kanban view, but I always got this error: Invalid XML for View Architecture! Here is the code:

> <record model="ir.ui.view"
> id="genial_2013_kanban_view">
>         <field name="name">Genial 2013 Kanban</field>
>         <field name="model">genial.2013</field>
>         <field name="type">kanban</field>
>         <field name="arch" type="xml">
>             <kanban>
>                 <field name="azienda"/>
>                 <field name="indirizzo"/>
>                 <field name="localita"/>
>                 <field name="provin"/>
>                 <templates>
>                     <t t-name="kanban-box">
>                             <div>
>                                 <h4><a type="open"><field
> name="azienda"/></a></h4>
>                                     <ul>
>                                         <li><field name="indirizzo"/></li>
>                                         <li><field name="localita"/></li>
>                                         <li><field name="provin"/></li>
>                                     </ul>
>                             </div>
>                     </t>
>                 </templates>
>             </kanban>
>         </field>
>     </record>

I can't see what's wrong!

Would you post the full traceback you are getting? <field name="type">kanban</field> is not required, you can remove it.

Nehal
on 5/7/14, 2:03 AM

Thank you for having well formatted the code (how can I do it when I post?). No traceback. I simply get the following message: ValidateError

Error occurred while validating the field(s) arch: Invalid XML for View Architecture!

Andrea Dalseno
on 5/7/14, 4:43 AM

Select the lines of code and press the link shown @ http://awesomescreenshot.com/0872rkpkf9 . This way you will be having code format.

Nehal
on 5/7/14, 7:18 AM
0
Andrea Dalseno
On 5/7/14, 6:42 AM

Solved! I made a mistake in the field declaration in the module file and called the field provin as 'provin ' with a final space!, so the name didn't match. Now the kanban view loads fine.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 5/6/14, 8:03 PM
Seen: 1120 times
Last updated: 3/16/15, 8:10 AM