Odoo Help


Error in installation of odoo in ubuntu 16.04

on 4/19/16, 8:40 AM 5,771 views


i am using ubuntu 16.04 i want to install odoo v9 in it

i follow these steps

To install Odoo 9.0 on Debian-based distribution, execute the following commands as root:

# wget -O - https://nightly.odoo.com/odoo.key | apt-key add -
# echo "deb http://nightly.odoo.com/9.0/nightly/deb/ ./" >> /etc/apt/sources.list
# apt-get update && apt-get install odoo

but it return error like

/var/lib/dpkg/info/odoo.postinst: 28: /var/lib/dpkg/info/odoo.postinst: update-python-modules: not found

dpkg: error processing package odoo (--configure):

subprocess installed post-installation script returned error exit status 127

Errors were encountered while processing:


E: Sub-process /usr/bin/dpkg returned an error code (1)

how can i solve this error .

16.04 is just a couple of days old and I'm not even using it on my desktop and will for sure wait for another 2 months and you want to install a complex server application on it???? I'm sure you will face plenty of any kind of weird problems and dependency issues, especially considering many "old" libraries Odoo 9.0 is still relying on. Why not use 14.04?

Ermin Trevisan
on 4/19/16, 4:10 PM

Jignesh Mehta

--Jignesh Mehta--
| 6 5 8
Surat, India
--Jignesh Mehta--

- I have 3+ years of Industry Experience, specializing Odoo Development, Analysis, Customization, Implementation, Integration.
- I have done many Customization modules in Sale, Purchase, Point of Sale, Inventory, CRM and much more. Also Worked in the Odoo Themes like Business Theme or E-Commerce Theme.
- Develop Jewelery Manufacturing process from Scratch. It have more than 10 Department. Develop PDF and Excel reports for this project around 150 per format.

Jignesh Mehta
On 4/19/16, 8:48 AM

Hello Kartik,

Follow command will helps you.

sudo rm /var/lib/apt/lists/lock

sudo rm /var/cache/apt/archives/lock

sudo apt-get update


jigneshm@Jigneshm:~$ cd /etc/apt/sources.list.d/

jigneshm@Jigneshm:/etc/apt/sources.list.d$ ls

chris-lea-node_js-precise.list     google-chrome.list.save         google.list        google.list.save      google-talkplugin.list.save


Go to sources.list.d folder through terminal.

After ls command fired. so all list is appeared.

Now remove folder which is install more than one time.



I follow you steps but still it return same error and in sudo apt-get update it will return error like "W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list:89 and /etc/apt/sources.list:90 "

on 4/19/16, 9:00 AM

hi ifollow your step i removed entry from sources.list.d after i give command "sudo apt-get update && sudo apt-get install odoo but it return same error ""

on 4/20/16, 12:29 AM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

2 follower(s)


Asked: 4/19/16, 8:40 AM
Seen: 5771 times
Last updated: 4/27/16, 3:41 AM