Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

ERROR dataup openerp.netsvc: The model "res.partner.address" specifies an unexisting parent class "res.partner.address" You may

By
NIcolas Plée
on 4/28/13, 1:54 PM 3,550 views

Hi, I don't know where the following error comes from and most important thing how to get rid of it. It keeps poping up for each installation of a new app or extra app.

Client Traceback (most recent call last):
  File "/opt/openerp/web/addons/web/http.py", line 204, in dispatch
    response["result"] = method(self, **self.params)
  File "/opt/openerp/web/addons/web/controllers/main.py", line 1133, in call_button
    action = self._call_kw(req, model, method, args, {})
  File "/opt/openerp/web/addons/web/controllers/main.py", line 1121, in _call_kw
    return getattr(req.session.model(model), method)(*args, **kwargs)
  File "/opt/openerp/web/addons/web/session.py", line 43, in proxy
    result = self.proxy.execute_kw(self.session._db, self.session._uid, self.session._password, self.model, method, args, kw)
  File "/opt/openerp/web/addons/web/session.py", line 31, in proxy_method
    result = self.session.send(self.service_name, method, *args)
  File "/opt/openerp/web/addons/web/session.py", line 104, in send
    raise xmlrpclib.Fault(openerp.tools.ustr(e), formatted_info)

Server Traceback (most recent call last):
  File "/opt/openerp/web/addons/web/session.py", line 90, in send
    return openerp.netsvc.dispatch_rpc(service_name, method, args)
  File "/opt/openerp/server/openerp/netsvc.py", line 293, in dispatch_rpc
    result = ExportService.getService(service_name).dispatch(method, params)
  File "/opt/openerp/server/openerp/service/web_services.py", line 626, in dispatch
    res = fn(db, uid, *params)
  File "/opt/openerp/server/openerp/osv/osv.py", line 188, in execute_kw
    return self.execute(db, uid, obj, method, *args, **kw or {})
  File "/opt/openerp/server/openerp/osv/osv.py", line 131, in wrapper
    return f(self, dbname, *args, **kwargs)
  File "/opt/openerp/server/openerp/osv/osv.py", line 197, in execute
    res = self.execute_cr(cr, uid, obj, method, *args, **kw)
  File "/opt/openerp/server/openerp/osv/osv.py", line 185, in execute_cr
    return getattr(object, method)(cr, uid, *args, **kw)
  File "/opt/openerp/server/openerp/addons/base/module/module.py", line 424, in button_immediate_install
    return self._button_immediate_function(cr, uid, ids, self.button_install, context=context)
  File "/opt/openerp/server/openerp/addons/base/module/module.py", line 475, in _button_immediate_function
    _, pool = pooler.restart_pool(cr.dbname, update_module=True)
  File "/opt/openerp/server/openerp/pooler.py", line 39, in restart_pool
    registry = RegistryManager.new(db_name, force_demo, status, update_module)
  File "/opt/openerp/server/openerp/modules/registry.py", line 218, in new
    openerp.modules.load_modules(registry.db, force_demo, status, update_module)
  File "/opt/openerp/server/openerp/modules/loading.py", line 348, in load_modules
    processed = load_marked_modules(cr, graph, states_to_load, force, status, report, loaded_modules, update_module)
  File "/opt/openerp/server/openerp/modules/loading.py", line 259, in load_marked_modules
    loaded, processed = load_module_graph(cr, graph, progressdict, report=report, skip_modules=loaded_modules, perform_checks=perform_checks)
  File "/opt/openerp/server/openerp/modules/loading.py", line 164, in load_module_graph
    models = pool.load(cr, package)
  File "/opt/openerp/server/openerp/modules/registry.py", line 118, in load
    model = cls.create_instance(self, cr)
  File "/opt/openerp/server/openerp/osv/orm.py", line 874, in create_instance
    'You may need to add a dependency on the parent class\' module.' % (name, parent_name))
TypeError: The model "res.partner.address" specifies an unexisting parent class "res.partner.address"
You may need to add a dependency on the parent class' module.

Thanks for any help

In V7 res.partner.address doest'n exist

MBIANDJI
on 5/7/13, 8:52 AM
0
kuité tagne tresor
On 12/27/13, 8:11 AM

i change res.partner.address to res.partner in asterisk 360.py but is not working. please how can i do to install res.partner object and what in directory or folder

0

Francesco OpenCode

--Francesco OpenCode--
3608
| 5 7 9
Grottaglie, Italy
--Francesco OpenCode--

Italian Odoo (OpenERP) Modules Developer LINKEDIN: http://www.linkedin.com/in/francescoapruzzese

Francesco OpenCode
On 4/28/13, 2:01 PM

If you use OpenERP v6 or v6.1

Try to add "base" as dipendence in your __openerp__.py file

If you use OpenERP v7

res.partner.address is a deprecated class in this OpenERP version. Please, use res.partner with parent_id correct use to solve problem in your code.

Thanks for your fast reply Francesco. This error happens with all type of apps installation or uninstallation. I checked one of the __openerp__.py file from the app I tried to install and base was already mentioned as a dependency.

NIcolas Plée
on 4/28/13, 2:21 PM

I precise that I'm on v7 and try to install v7 apps.

NIcolas Plée
on 4/28/13, 2:37 PM

In v7, res.partner.address object has been removed. You need to use res.partner object instead of that.

Priyesh Solanki (pso)
on 4/29/13, 4:59 AM

@Nicolas If you use V7 the correct answer is the Priyesh Solanki's answer. I update my post.

Francesco OpenCode
on 4/29/13, 5:59 AM

Thanks both of you for the interest but I'm a bit confused. Why should I change those files if the y're part of official openerp apps ? As I said the error happens for installation and uninstallation of official and extra OpenERp apps.

NIcolas Plée
on 4/29/13, 6:40 AM

I am not sure but it should be issue with extra OpenERP Apps as with official 7.0 version, I am not getting such error. May be extra modules, those you are using, its been compatible with 6.1 instead of 7.0.

Priyesh Solanki (pso)
on 4/29/13, 7:00 AM

What app take you this error?

Francesco OpenCode
on 4/29/13, 7:35 AM

I guess all of them ;-) point_of_sale : to install hr : to remove hr_timesheet : to install hr_timesheet_sheet : to install hr_recruitment : to remove hr_holidays : to remove hr_expense : to remove assignment_product_clients : to install hr_attendance : to install hr_timesheet_invoice : to install

This is the list of apps I tried to install or uninstall with no success.

NIcolas Plée
on 4/29/13, 8:29 AM

I doubt on this module assignment_product_clients. I search it in apps.openerp.com and found that its compatible with 6.0 version, not even for 6.1 and 7.0. May be this is creating an issue.

Priyesh Solanki (pso)
on 4/29/13, 8:51 AM

Actually assignment_product_clients is in development for v7. I tried to make the install that obviously didn't work to check if the module could be interesting when fully developed for v7. Actual dependencies for this version are base and products. Any idea how I could resolve this or should I think about seting up a new install ?

NIcolas Plée
on 4/29/13, 11:18 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 4/28/13, 1:54 PM
Seen: 3550 times
Last updated: 3/16/15, 8:10 AM