Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Error curl call xml-rpc res.users model (search_read)

By
Jose M. González
on 5/5/16, 7:38 AM 413 views

Hi, 


I'm trying to make a xml- rpc call via curl but it returns an error that I can not solve.
Anyone can help ?, thank you very much .

This is the call that I do and the error returned by me :

curl -k https://erp.xxxxxxxx.com/xmlrpc/object --data 
"<methodCall><methodName>execute</methodName>
<param><value>mybbdd</value></param>
                <param><value>149</value></param> <param><value>pass</value></param>
<param><value>res.users</value></param>
                <param><value>search_read</value></param>
<param>
<param><value><array>
<param><value><array>
<param><value><string>user_ids</string></value></param>
<param><value><string>=</string></value></param>
<param><value><int>149</int></value></param>
</array></value></param>
</array></value></param>
</param>
</methodCall>"

but this call give me this error:

<?xml version='1.0'?>
<methodResponse>
<fault>
<value><struct>
<member>
<name>faultCode</name>
<value><string>warning -- AccessError
No value found for res.users('149',).company_id</string></value>
</member>
<member>
<name>faultString</name>
<value><string></string></value>
</member>
</struct></value>
</fault>
</methodResponse>

change the username or provide group access to the currently user used in xml rpc for authenticate.

Prakash Sharma
on 5/6/16, 1:58 AM

thanks for the reply , try this , but have the same error. I tried also specify the fields that I want you to give me but nothing ...

Jose M. González
on 5/11/16, 4:19 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 5/5/16, 7:38 AM
Seen: 413 times
Last updated: 5/5/16, 7:51 AM