Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Error creating a database v9

Paulo Matos‏
on 10/8/15, 4:26 PM 938 views

Dear all,

Today, after a fresh install of Odoo v9, I get the attached error when trying to create a new database. The error is:

Database creation error: "Mixing apples and oranges: None in res.groups(5, 4)" while parsing /opt/odoo/openerp/addons/base/security/base_security.xml:18, near

<record model="res.groups" id="group_system">
<field name="name">Settings</field>
<field name="implied_ids" eval="[(4, ref('group_erp_manager'))]"/>
<field name="users" eval="[(4, ref('base.user_root'))]"/>

I have confirmed everything and my odoo-server.conf is: 

admin_passwd = admin
db_host = False
db_port = False
db_user = odoo
db_password = admin
addons_path = /opt/odoo/addons

User odoo is already created on postgresql and the password set is "admin".

This is not the first time I install odoo 9 using the method used, and never had problem like this.

What could be the reason?



Did you try to create a db with demo data?

Akhil P Sivan
on 10/9/15, 1:05 AM

I got the same error. I tried both with and without demo data, but in both occasions the same error occurs.

on 10/9/15, 6:28 AM
Karthik Arumugam
On 10/9/15, 6:42 AM

Hi Paulo Matos,

               You need to add one more path in addons (ie) /opt/odoo/openerp/addons

                This path contains the base modules

                Thats why the error raising while accessing the base group

                After editing your addons path look like this addons_path = addons_path = /opt/odoo/addons, /opt/odoo/openerp/addons


Dear Karthik, thank you very much for the update.

ThinkOpen Solutions (Angola), Paulo Matos‏
on 10/9/15, 6:46 AM
Kéri Krisztián
On 10/9/15, 7:00 AM


Strange. After this error, i removed the whole content of /opt/odoo and cloned the master branch into it. No change on config file. It is created the database without error. Then i cloned back the 9.0 branch and works perfect.

Perhaps was branch error since I had myself installed odoo 9 with no errors. The first time I saw this error was on yesterday branch.

ThinkOpen Solutions (Angola), Paulo Matos‏
on 10/9/15, 7:09 AM
Karthik Arumugam
On 10/9/15, 6:39 AM

Hi Paulo Matos,

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

4 follower(s)


Asked: 10/8/15, 4:26 PM
Seen: 938 times
Last updated: 10/9/15, 7:00 AM