Odoo Help

0

Error causes inability to access "edit view" in developers mode

By
Raphael
on 12/2/15, 6:09 AM 1,052 views

We are struggling to resolve the following error:

"Uncaught TypeError: Cannot read property 'name' of undefined

http://odoo-01.forsberg.local:8085/web/static/src/js/view_list.js:443"

It occured by adding an erroneous line of code to the tree view "mrp.production" (Wanted to initiate a column order by including "_order = "X_Delivery_date_ToFSLSales". Unfortunately this did not work and crashed the module mrp.production).

Due to this line of code we can’t access the tree view architecture in the developers mode any more and can't get rid of the line of code. The option to access "edit view" is not anymore available (drop down list is empty)

Is there any other way to remove this line of code from the tree view architecture or how can this problem be fixed?

Thank you very much for the quick answer! Worked. Solved.

Raphael
on 12/2/15, 11:18 AM
0
Zbik
On 12/2/15, 10:23 AM

You go to menu //Settings/User Interface/Views, search the bad view and correct it.

Or directly search in the database in table ir_ui_view.

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 12/2/15, 6:09 AM
Seen: 1052 times
Last updated: 6/16/16, 4:06 PM