Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

error attached file not found

By
zilvinas
on 9/4/15, 2:42 AM 458 views

i am using Odoo v8. 

I was wondering where are stored attached file and started searchin whem on my centos 6 + odoo v8 installation. i didnt found them so decided to create new

system parameter: ir_attachment.location

with value: file

and in server_conf file addeded data_dir = /opt/odoo/filestore


Newly atttached files are stored and can be viewed from odoo, but old ones are not found. 

0
zilvinas
On 9/4/15, 3:28 AM

on my installation no such directory, also i tried search in usr/local/share/ filestore or odoo and usr/share/ filestore.

in /var/lib no such directory odoo. my odoo installation is on opt/odoo and before changing ir_attachment parameter was no directory filestore. Now it is where, but without old files, i thin whey left in db.

zilvinas
on 9/4/15, 3:38 AM

I have tried to delete ir_attachemnt parameter and comment data_dir line in server conf. and now i can see old attached files. how to migrate whem all to one plave in filestore

zilvinas
on 9/4/15, 3:43 AM

I have found old files in /home/odoo_user/.local/share/Odoo/filestore/dbname

zilvinas
on 9/4/15, 3:50 AM

you are right I just read quickly the function that build the filestore path and misunderstood the path generated. The one that I mention to you is built when the user home doesn't exist

Axel Mendoza
on 9/4/15, 4:10 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 9/4/15, 2:42 AM
Seen: 458 times
Last updated: 9/4/15, 4:07 AM