Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

error after restart server on production (SOLVED)

By
henro
on 8/25/15, 5:53 AM 608 views

hi to all,
after i restart server in production , i get this error when login to erp :

please help .


bzr: warning: unsupported locale setting

bzr could not set the application locale.

Although this should be no problem for bzr itself,

it might cause problems with some plugins.

To investigate the issue, look at the output

of the locale(1p) tool available on POSIX systems.

bzr: ERROR: Not a branch: "/home/test/test-erp-server-5.0.14/bin/".

[2015-08-25 16:30:17,577][ABLEPACK_PRODUCTION] CRITICAL:init:[01]:

[2015-08-25 16:30:17,577][ABLEPACK_PRODUCTION] CRITICAL:init:[02]: Environment Information :

[2015-08-25 16:30:17,577][ABLEPACK_PRODUCTION] CRITICAL:init:[03]: System : Linux-2.6.32-38-server-x86_64-with-Ubuntu-10.04-lucid

[2015-08-25 16:30:17,577][ABLEPACK_PRODUCTION] CRITICAL:init:[04]: OS Name : posix

[2015-08-25 16:30:17,577][ABLEPACK_PRODUCTION] CRITICAL:init:[05]: Distributor ID: Ubuntu

[2015-08-25 16:30:17,577][ABLEPACK_PRODUCTION] CRITICAL:init:[06]: Description:Ubuntu 10.04.4 LTS

[2015-08-25 16:30:17,577][ABLEPACK_PRODUCTION] CRITICAL:init:[07]: Release: 10.04

[2015-08-25 16:30:17,577][ABLEPACK_PRODUCTION] CRITICAL:init:[08]: Codename: lucid

[2015-08-25 16:30:17,577][ABLEPACK_PRODUCTION] CRITICAL:init:[09]: Operating System Release : 2.6.32-38-server

[2015-08-25 16:30:17,578][ABLEPACK_PRODUCTION] CRITICAL:init:[10]: Operating System Version : #83-Ubuntu SMP Wed Jan 4 11:26:59 UTC 2012

[2015-08-25 16:30:17,578][ABLEPACK_PRODUCTION] CRITICAL:init:[11]: Operating System Architecture : 64bit

[2015-08-25 16:30:17,578][ABLEPACK_PRODUCTION] CRITICAL:init:[12]: Operating System Locale : en_US.UTF8

[2015-08-25 16:30:17,578][ABLEPACK_PRODUCTION] CRITICAL:init:[13]: Python Version : 2.6.5

[2015-08-25 16:30:17,578][ABLEPACK_PRODUCTION] CRITICAL:init:[14]: TigernixERP-Server Version : 5.0.14

[2015-08-25 16:30:17,578][ABLEPACK_PRODUCTION] CRITICAL:init:[15]: Last revision No. & ID :

[2015-08-25 16:30:17,578][ABLEPACK_PRODUCTION] CRITICAL:init:[16]: Couldn't load module ablepack_project

bzr: warning: unsupported locale setting

bzr could not set the application locale.

Although this should be no problem for bzr itself,

it might cause problems with some plugins.

To investigate the issue, look at the output

of the locale(1p) tool available on POSIX systems.

bzr: ERROR: Not a branch: "/home/teest/test-server-5.0.14/bin/".

[2015-08-25 16:30:17,667][ABLEPACK_PRODUCTION] CRITICAL:init:[01]:

[2015-08-25 16:30:17,667][ABLEPACK_PRODUCTION] CRITICAL:init:[02]: Environment Information :

[2015-08-25 16:30:17,667][ABLEPACK_PRODUCTION] CRITICAL:init:[03]: System : Linux-2.6.32-38-server-x86_64-with-Ubuntu-10.04-lucid

[2015-08-25 16:30:17,668][ABLEPACK_PRODUCTION] CRITICAL:init:[04]: OS Name : posix

[2015-08-25 16:30:17,668][ABLEPACK_PRODUCTION] CRITICAL:init:[05]: Distributor ID: Ubuntu

[2015-08-25 16:30:17,668][ABLEPACK_PRODUCTION] CRITICAL:init:[06]: Description:Ubuntu 10.04.4 LTS

[2015-08-25 16:30:17,668][ABLEPACK_PRODUCTION] CRITICAL:init:[07]: Release: 10.04

[2015-08-25 16:30:17,668][ABLEPACK_PRODUCTION] CRITICAL:init:[08]: Codename: lucid

[2015-08-25 16:30:17,668][ABLEPACK_PRODUCTION] CRITICAL:init:[09]: Operating System Release : 2.6.32-38-server

[2015-08-25 16:30:17,668][ABLEPACK_PRODUCTION] CRITICAL:init:[10]: Operating System Version : #83-Ubuntu SMP Wed Jan 4 11:26:59 UTC 2012

[2015-08-25 16:30:17,668][ABLEPACK_PRODUCTION] CRITICAL:init:[11]: Operating System Architecture : 64bit

[2015-08-25 16:30:17,668][ABLEPACK_PRODUCTION] CRITICAL:init:[12]: Operating System Locale : en_US.UTF8

[2015-08-25 16:30:17,668][ABLEPACK_PRODUCTION] CRITICAL:init:[13]: Python Version : 2.6.5

[2015-08-25 16:30:17,668][ABLEPACK_PRODUCTION] CRITICAL:init:[14]: TigernixERP-Server Version : 5.0.14

[2015-08-25 16:30:17,668][ABLEPACK_PRODUCTION] CRITICAL:init:[15]: Last revision No. & ID :

[2015-08-25 16:30:17,668][ABLEPACK_PRODUCTION] CRITICAL:init:[16]: unsupported locale setting

1
pks
On 8/25/15, 9:59 AM

Check you server log file,reffed this http://stackoverflow.com/questions/1830394/python-locale-strange-error-whats-going-on-here-exactly

0
henro
On 8/27/15, 12:48 AM

Thanks to prasanth.ks.
i have solved this with this way : 

Add this Code:

LC_ALL="en_GB.utf8"

to /etc/environment and rebooting.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 8/25/15, 5:53 AM
Seen: 608 times
Last updated: 8/27/15, 12:48 AM