Odoo Help

0

Error after installing website-report module

By
Dale
on 7/14/15, 8:09 AM 1,576 views

Good day


i installed the website_report module in Odoo 8 and now I cannot log into my databases. I am getting the following errors:

Could not get content for /web/static/lib/boostrap/css/bootstrap.css defined in bundle 'website.assets_frontend'

Could not get content for /website/static/src/css/website.css defined in bundle 'website.assets_frontend'

Could not get content for /website_mail/static/src/css/website_mail.css defined in bundle 'website.assets_frontend'

Could not get content for /web_graph_static/src/css/nv.d3.css defined in bundle 'website.assets_frontend'

Could not get content for /survey/static/src/css/survey_results.css defined in bundle 'website.assets_frontend'


Please help


Thanks  



0
FEDERICO LEONI
On 7/14/15, 10:11 AM

Are you sure the issue started with this specific module?

Could be a corrupted module. Assuming you are using V8 on a local server, download website_report again from here and overwrite the one on

/odoo/addons/

Please make sure permission are right, have a look on another folder to see how to set them.

Start the server with

./odoo.py -u website_report 

or, if you are using Windows

python odoo.py -u website_report

to see if the problem was solved. If not there is a problem on website model and could be potentially a faulty installation. Please remember you can not uninstall a module from a console but just from GUI or managing manually the ir_module_module table marking the module as uninstalled

Thanks Federico. I can only think that the problem started with this module because we have been running for months until I installed it. I will try this thanks

Dale
on 7/14/15, 10:29 AM

Please rate my reply then, and please please please! Don't open two threads with the same subject... ;)

FEDERICO LEONI
on 7/14/15, 10:47 AM

Federico I ran these steps and I am still having the same problem even after I reloaded that module. It seems all the errors are in a subfolder called static. What else can I try?

Dale
on 7/14/15, 11:03 AM

Now I have these errors when I start the server: odoo@ubuntu:/home/wyradmin$ /opt/odoo/odoo.py -u website_report 2015-07-14 15:04:45,481 1184 INFO ? openerp: OpenERP version 8.0 2015-07-14 15:04:45,482 1184 INFO ? openerp: addons paths: ['/opt/odoo/.local/share/Odoo/addons/8.0', u'/opt/odoo/openerp/addons', u'/opt/odoo/addons'] 2015-07-14 15:04:45,482 1184 INFO ? openerp: database hostname: localhost 2015-07-14 15:04:45,482 1184 INFO ? openerp: database port: 5432 2015-07-14 15:04:45,483 1184 INFO ? openerp: database user: odoo 2015-07-14 15:04:46,079 1184 INFO ? openerp.service.server: HTTP service (werkzeug) running on 0.0.0.0:8069 2015-07-14 15:05:08,541 1184 INFO ? werkzeug: 105.237.210.67 - - [14/Jul/2015 15:05:08] "GET / HTTP/1.1" 500 - 2015-07-14 15:05:08,556 1184 ERROR ? werkzeug: Error on request: Traceback (most recent call last): File "/usr/lib/python2.7/dist-packages/werkzeug/serving.py", line 177, in run_wsgi execute(self.server.app) File "/usr/lib/python2.7/dist-packages/werkzeug/serving.py", line 165, in execute application_iter = app(environ, start_response) File "/opt/odoo/openerp/service/server.py", line 281, in app return self.app(e, s) File "/opt/odoo/openerp/service/wsgi_server.py", line 216, in application return application_unproxied(environ, start_response) File "/opt/odoo/openerp/service/wsgi_server.py", line 202, in application_unproxied result = handler(environ, start_response) File "/opt/odoo/openerp/http.py", line 1279, in __call__ self.load_addons() File "/opt/odoo/openerp/http.py", line 1298, in load_addons m = __import__('openerp.addons.' + module) File "/opt/odoo/openerp/modules/module.py", line 80, in load_module mod = imp.load_module('openerp.addons.' + module_part, f, path, descr) File "/opt/odoo/.local/share/Odoo/addons/8.0/auto_backup/__init__.py", line 23, in import backup_scheduler File "/opt/odoo/.local/share/Odoo/addons/8.0/auto_backup/backup_scheduler.py", line 33, in raise ImportError('This module needs pysftp to automaticly write backups to the FTP through SFTP. Please install pysftp on your system. (sudo pip install pysftp)') ImportError: This module needs pysftp to automaticly write backups to the FTP through SFTP. Please install pysftp on your system. (sudo pip install pysftp) pshttp

Dale
on 7/14/15, 11:07 AM

Faulty installation or corrupted configuration for the first error. For the second you already have the solution:

sudo pip install pysftp
FEDERICO LEONI
on 7/14/15, 11:44 AM
0
Dale
On 7/14/15, 11:25 AM


Hi All

I found the problem. It seems that another user installed an autobackup module which needed more work. I hadn't restarted the server in a very long time so when i installed the new module and restarted i assumed the problem was with the new module. Thanks for all the input!

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 7/14/15, 8:09 AM
Seen: 1576 times
Last updated: 7/14/15, 11:27 AM