Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

error after install [Closed]

By
turalo
on 2/9/13, 8:16 PM 4,492 views

The Question has been closed for reason: not a real question

by
Ahmet Altinisik
on 02/26/2013 18:45:22

Hi guys, I'm totally new to OpenERP. I have tried for few days now to install it mannually, that didnot work, so I used the script from the forum. All install went well sofar I could follow. but now I have 2 problems.

  1. I'm getting an big error as soon as I open the page in my browser.

  2. I'm unable to login. I see the red page of OpenERP, then the login box, and in the right top I see a field saying Database, when I click on manage databases at the lower left corner of login box nothing happens. it goes to a blanc page.

here is the error that i get :

Client Traceback (most recent call last): File "/usr/lib/python2.6/site-packages/openerp-7.020130209002058-py2.6.egg/openerp/addons/web/http.py", line 195, in dispatch response["result"] = method(self, **self.params) File "/usr/lib/python2.6/site-packages/openerp-7.020130209002058-py2.6.egg/openerp/addons/web/controllers/main.py", line 709, in getlist return dblist(req) File "/usr/lib/python2.6/site-packages/openerp-7.020130209002058-py2.6.egg/openerp/addons/web/controllers/main.py", line 88, in dblist dbs = proxy.list() File "/usr/lib/python2.6/site-packages/openerp-7.020130209002058-py2.6.egg/openerp/addons/web/session.py", line 31, in proxymethod result = self.session.send(self.servicename, method, *args) File "/usr/lib/python2.6/site-packages/openerp-7.020130209002058-py2.6.egg/openerp/addons/web/session.py", line 104, in send raise xmlrpclib.Fault(openerp.tools.ustr(e), formattedinfo)

Server Traceback (most recent call last): File "/usr/lib/python2.6/site-packages/openerp-7.020130209002058-py2.6.egg/openerp/addons/web/session.py", line 90, in send return openerp.netsvc.dispatchrpc(servicename, method, args) File "/usr/lib/python2.6/site-packages/openerp-7.020130209002058-py2.6.egg/openerp/netsvc.py", line 295, in dispatchrpc result = ExportService.getService(servicename).dispatch(method, params) File "/usr/lib/python2.6/site-packages/openerp-7.020130209002058-py2.6.egg/openerp/service/webservices.py", line 122, in dispatch return fn(*params) File "/usr/lib/python2.6/site-packages/openerp-7.020130209002058-py2.6.egg/openerp/service/webservices.py", line 351, in explist cr = db.cursor() File "/usr/lib/python2.6/site-packages/openerp-7.020130209002058-py2.6.egg/openerp/sqldb.py", line 477, in cursor return Cursor(self.pool, self.dbname, serialized=serialized) File "/usr/lib/python2.6/site-packages/openerp-7.020130209002058-py2.6.egg/openerp/sqldb.py", line 183, in init self.cnx = pool.borrow(dsn(dbname)) File "/usr/lib/python2.6/site-packages/openerp-7.020130209002058-py2.6.egg/openerp/sqldb.py", line 378, in locked return fun(self, *args, **kwargs) File "/usr/lib/python2.6/site-packages/openerp-7.020130209002058-py2.6.egg/openerp/sqldb.py", line 433, in borrow result = psycopg2.connect(dsn=dsn, connection_factory=PsycoConnection) OperationalError: could not connect to server: No such file or directory Is the server running locally and accepting connections on Unix domain socket "/tmp/.s.PGSQL.5432"?

here is the install script that I have used, its an CENT OS 6.3 Installation. I have edited the download links because otherwise I was unable to post it here, cause my karma was to low to post links.

#!/bin/sh

Modified script from Carlos E. Fonseca Zorrilla

yum -y install wget unzip rpm -ivh /dl.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm rpm -ivh //yum.pgrpms.org/9.2/redhat/rhel-6-i386/pgdg-centos92-9.2-6.noarch.rpm yum -y install python-psycopg2 python-lxml PyXML python-setuptools libxslt-python pytz \ python-matplotlib python-babel python-mako python-dateutil python-psycopg2 \ pychart pydot python-reportlab python-devel python-imaging python-vobject \ hippo-canvas-python mx python-gdata python-ldap python-openid \ python-werkzeug python-vatnumber pygtk2 glade3 pydot python-dateutil \ python-matplotlib pygtk2 glade3 pydot python-dateutil python-matplotlib \ python python-devel python-psutil python-docutils make\ automake gcc gcc-c++ kernel-devel byacc flashplugin-nonfree poppler-utils pywebdav\ yum -y install postgresql92-libs postgresql92-server postgresql92 service postgresql-9.2 initdb chkconfig postgresql-9.2 on service postgresql-9.2 start su - postgres -c "createuser --superuser openerp" cd /tmp wget gdata-python-client.googlecode.com/files/gdata-2.0.17.zip unzip gdata-2.0.17.zip rm -rf gdata-2.0.17.zip cd gdata* python setup.py install cd /tmp adduser openerp DIR="/var/run/openerp /var/log/openerp" for NAME in $DIR do if [ ! -d $NAME ]; then mkdir $NAME chown openerp.openerp $NAME fi done rm -rf openerp* wget nightly.openerp.com/7.0/nightly/src/openerp-7.0-latest.tar.gz tar -zxvf openerp-7.0-latest.tar.gz --transform 's!^[^/]+($\|/)!openerp\1!' cd openerp python setup.py install rm -rf /usr/local/bin/openerp-server cp openerp-server /usr/local/bin cp install/openerp-server.init /etc/init.d/openerp cp install/openerp-server.conf /etc chown openerp:openerp /etc/openerp-server.conf chmod u+x /etc/init.d/openerp chkconfig openerp on service openerp start

Please help / advice.

thanks in advance.

0

Martin

--Martin--
1978
| 5 6 8
Cornwall, Canada
--Martin--

Analysing, designing, coding and mentoring since 1975. Kilobytes to terabytes. Punch cards to punchy sites. My OpenERP video series: http://www.youtube.com/playlist?list=PLq7op4J183lX44ZlXPiHxUpRvmmRDtxye My Google Speadsheets --> OpenERP Data Pump project: http://martinhbramwell.github.io/GData_OpenERP_Data_Pump My email (with spaces removed) : mhb . warehouseman @ gmail . com

Martin
On 2/9/13, 9:09 PM

The text "('AccessDenied', openerp.tools.ustr(e))" strongly suggests problems with your access to the database.

You should ensure that you can connect to PostgreSQL using psql on the command line specifying the IP address in the command. (Personally, I prefer to try access from a different machine entirely.)

Can you access your OpenERP database with a command line instruction like this?

psql -h x.x.x.x -U openErpUID openErpDB

Until you can, you will achieve nothing trying to access via OpenERP itself

I recommend you Google some postgres getting started tutorials. Eg; http://stackoverflow.com/questions/1471571/how-to-configure-postgresql-for-the-first-time

In particular you should be confident with the necessary changes in "pg_hba.conf" and "postgresql.conf".

This helped me a lot http://www.theopensourcerer.com/2012/12/how-to-install-openerp-7-0-on-ubuntu-12-04-lts/

Go4OpenERP, Jan Pompe
on 2/9/13, 9:34 PM

Well I have created the users, and databases via webmin, and gived the needed permissions, and yes I can acces it,

[root@localhost ~]# su openerp [openerp@localhost root]$ psql could not change directory to "/root" psql (8.4.13) Type "help" for help.

openerp=#

turalo
on 2/10/13, 7:02 AM

Alright, the system is working, now I know what the problem was, at the initial first screen after install I was typing in my own password, while it was not righ, it was just "admin" the default. But the way to this was long, cause I have reinstalled all again, from zero, Ubuntu server etc...

turalo
on 2/10/13, 1:56 PM

Congratulations!

Martin
on 2/11/13, 6:42 AM

Do you consider that your problem was resolved? If so you'll help others but indicating that with the "answered" check mark

Martin
on 3/1/13, 10:01 PM
0
turalo
On 2/9/13, 8:48 PM

now, I have found out that I didnot have any postgress installed, so I have installed postgres server, and now it works, but when I'm creating the database on the first page of OPEN ERP, it shows me this error :

OpenERP Server Error

Client Traceback (most recent call last): File "/usr/lib/python2.6/site-packages/openerp-7.020130209002058-py2.6.egg/openerp/addons/web/http.py", line 195, in dispatch response["result"] = method(self, **self.params) File "/usr/lib/python2.6/site-packages/openerp-7.020130209002058-py2.6.egg/openerp/addons/web/controllers/main.py", line 719, in create params['createadminpwd']) File "/usr/lib/python2.6/site-packages/openerp-7.020130209002058-py2.6.egg/openerp/addons/web/session.py", line 31, in proxymethod result = self.session.send(self.servicename, method, *args) File "/usr/lib/python2.6/site-packages/openerp-7.020130209002058-py2.6.egg/openerp/addons/web/session.py", line 98, in send raise xmlrpclib.Fault('AccessDenied', openerp.tools.ustr(e))

Server Access denie

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 2/9/13, 8:16 PM
Seen: 4492 times
Last updated: 3/16/15, 8:10 AM