Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

5

ERP7 Document Management Folders Per Resource?

By
mike
on 4/3/13, 6:03 PM 2,431 views

Is this addon broken? I am trying to have it create a directory for each partner which is something it's supposed to do if needed. The "help" says...

Each directory can either have the type Static or be linked to another resource. A static directory, as with Operating Systems, is the classic directory that can contain a set of files. The directories linked to systems resources automatically possess sub-directories for each of resource types defined in the parent directory.

So I set the Partners directory to "Folders per resource" and set Resource Model to Partner. For this field "help" says...

Select an object here and there will be one folder per record of that resource.

Yet no directory per partner after this change. The "Find all Resources" option seemingly has no effect either. Nor does "Parent Model" or "Tree Structure". In fact I am finding that no matter how I configure the settings I just wind up with a static directory no matter what.

Has anybody gotten this addon to work as advertised at all? If so, could you please share what you did?

I can confirm the problem mike is facing. No matter which "Parent Models" or "Generated Files" lines I try, I can only see the saved attachments as documents without Directory in the Knowledge->Documents list. By hand, it is possible to move a document to some directory defined at the "Directories". It would be nice to know how this feature should work and which configuration settings are needed besides the modules.

LUOSTO COMMUNICATIONS, Markku Luosto
on 4/4/13, 6:28 AM

I have added a bug in Launchpad - 1164655

mike
on 4/4/13, 4:17 PM

There has been activity on this bug, including a video - https://bugs.launchpad.net/openobject-addons/+bug/1164655

mike
on 5/1/13, 3:02 PM
2
Gregor Heger
On 7/12/15, 4:28 AM

Hi,

I would like to wake up this thread. Now, we have the 12th July 2015 and still the document management system in Odoo is broken.

It is still not possible to make the "Folders per Resource" feature work. As the initial poster described you can configure the document system as much as you want: Attachments won't get automatically archived in directories.

I googled everything I could find but did not find any user or company who made the feature work. Is there anyone? Thanks for any input..

Edit: I found some people guessing, that this feature only works together with the "Shared Repositories FTP" Module. But this is unfortunately not ported to version 8.

2

ton123

--ton123--
1418
| 5 6 9
Lisse, Netherlands
--ton123--
End-User. Installed 6.1.1 on a DS412+, DS211+ and DS113J Synology NAS. Reference installation on Ubuntu 12.04/Samsung Notebook. 12-03-2013 In production for Suppliers and Customers, adresbook. 7 small companies. Testing accounting, document management, import and export. Too much showstoppers I haven't fixed at this moment. 06-05-2013 little progress. Migration to v7 impossible because of missing Dutch localisation modules. What I see working is nice, so further testing and asking. Start testing products and warehouse. Happy with this forum and the community.
ton123
On 4/3/13, 6:57 PM

To answer your question in my case: No I have exactly the same problem on v6.1 . And I asked it elswere on this forum.

https://accounts.openerp.com/forum/Help-1/question/708

I wonder if this a known bug. Anyway I coudn't find it as such.

Maybe I am getting somewhere. In the definition for my partner folder I changed Domain to ['resource_find_all', '=', True]. Now the folder shows it has children folders. When I expand I find that a subfolder has been created for Suppliers. So it generated a subfolder for a partner category. Can I add more than one condition to Domain field?

mike
on 4/4/13, 10:52 AM

Nevermind, must have been a glitch. I deleted the Suppliers folder and it wasn't regenerated regardless of Domain filter. There's an hour of my day I won't get back LOL!

mike
on 4/4/13, 11:24 AM

OK this gives me hope for my own v6.1 installation.

ton123
on 4/4/13, 2:03 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 4/3/13, 6:03 PM
Seen: 2431 times
Last updated: 11/15/15, 2:08 AM