Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Empty module to force load of several others

By
E.M.
on 7/26/15, 4:59 PM 373 views

I would like to implement a module which forces load of others.

Is it ok to use an __openerp__.py whith the right dependences and an empty __init__.py?

I have tried an empty __init__.py and the following __openerp__.py:

{
'name': 'Base Module'
'description': 'Forces Installation of base modules'
'author': 'E.M.',
'depends': ['account_accountant', 'sale', 'stock', 'purchase', 'calendar', 'contacts', 'document'],
}

But module does not appear in the list despite the path is added and the server has been restarted.

I tried the same as your trial with no success, hope anyone offers help

Tarek Mohamed Ibrahim
on 7/26/15, 6:09 PM
1

Axel Mendoza

--Axel Mendoza--
10203
| 7 7 8
Camaguey, Cuba
--Axel Mendoza--

DevOps - Full stack - Software Architect - Developer - Technology Integrator

I could help you to develop anything and solve complex problems based on technologies, integrations and tricky stuffs mostly in Python with OpenERP/Odoo, Zato, Django and many others frameworks programming languages and technologies.

I offers consulting services to anyone with an unanswered questions or needs for customizations. Think about it, maybe it's better to have an expert to solve your issues and projects than having a full time employee trying to understand what to do an how

Reach me at aekroft@gmail.com

Axel Mendoza
On 7/26/15, 7:43 PM

You need to complete and fix the __openerp__.py dict, you need to correctly define a dict , could use something like this:


{
'name': 'Base Module',
'description': 'Forces Installation of base modules',
'author': 'E.M.',
'depends': ['account_accountant', 'sale', 'stock', 'purchase', 'calendar', 'contacts', 'document'],
      'auto_install': False,
        'application': True,
        'installable': True,

}


Thanks Axel, unfortunately adding those fields does not fix the issue. I double checked everything restarted server and uploaded the module list but still no success. Module is missing.

E.M.
on 7/27/15, 5:22 PM

If the previous fix is not working for you then you are facing permission issues. Check that the user used to run odoo have permission for the modules and also for the config file where you set the addons_path option normaly chown user -R /path/to/config/or/modules And chmod 755 -R /path/to/config/or/modules

Axel Mendoza
on 7/27/15, 5:42 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 7/26/15, 4:59 PM
Seen: 373 times
Last updated: 8/3/15, 4:52 PM