Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

2

Email is not fetching automatically

By
Gerry
on 5/16/13, 8:21 PM 7,138 views

Hi everyone,

Our Incoming Emails are NOT being fetched automatically. We are able to fetch the emails manually by clicking on the "Fetch Now" button however. All our "Incoming Mail Servers" profiles show the same old date. Newly created "incoming Mail Server" have the same problem.

Any assistance would be much appreciated.

have you checked the automated actions? The fetchmail action should be activated

Gustavo
on 5/16/13, 8:33 PM

Activate the schedulers it should be work.

sridhar
on 5/17/13, 3:26 AM

Did that. No effect. Again, the Fetchmail action stops working everytime I run the upgrade of OpenERP.

Gerry
on 6/6/13, 11:02 PM

Question - is it just your email thats not scheduling? - None of my schedulers are working! http://help.openerp.com/question/21748/scheduler-not-working/

Cameron
on 6/19/13, 8:08 AM

Theres a lot of talk about having your server running in UTC time for the scheduler - didnt make any difference to me though!

Cameron
on 6/20/13, 11:01 AM
2
Atchuthan
On 5/17/13, 3:27 AM

For automate fetching for e-mail:

Follow the procedures to autofetch Settings --> Technical --> Scheduler --> Scheduled Actions --> Select Fetchmail Service in the list. --> Edit --> Change the interval number and unit according to your need --> Save

Configuring for auto-fetch done.

No effect!

Gerry
on 6/6/13, 11:03 PM

I'm searching for this automated actions everywhere in 8.0dev-20140416-230101 I can see under apps that a plugin " Automated Action Rule " is installed, but I can't see any hint to neither "schudule", "automation" nor fetchmail in my "Settings" so where can I search to get the settings of the automated tasks in Odoo v8? all the best for you guys!

Malte Helmhold
on 9/15/14, 6:43 AM

sorry I can't delete my "answer" because I haven't enough karma:( now It's kinda duplication here. But I hope someone sees my cry for help;)

Malte Helmhold
on 9/15/14, 6:44 AM

Ok, I found out that you have to check for the admin or the user you want to enable the feature in order to see this settings: User Permissions -> Technical features without this enable the user can't see the settings needed for properly configure openERP. That's something an OpenERP beginner has to do hard work to find out! alas but anyway, it does not change the problem that mails are not fetched although fetchmail is set to 5 minutes in scheduled actions:(

Malte Helmhold
on 9/17/14, 8:25 AM

yes Atchuthan I tried the same. but it is not fetching for my user. is there any rights we have to give for the user to make it work?

Surendar
on 10/31/14, 1:17 AM
0
Ivan Yelizariev
On 7/8/15, 1:41 AM

Check value for max_cron_threads config. It should be non-zero.

0
Gerry
On 5/23/13, 4:34 AM

Thanks for the responses guys, unfortunately, the automatic Fetchmail functionality is already setup and running, but no trigger is actually registered.

The automatic incoming messages used to work perfectly fine before. I'm not sure when it stopped working whether being after an update or we switched our Amazon servers location (we transferred an image of our OpenERP server to another Amazon server location)...Not sure if that would break anything however.

What puzzles me in that OpenERP is not showing any attempt to fetch emails automatically. At least that's what the "Last Fetch Date" shows.

Any other thoughts?

You can try to upgrade "Email Gateway" as it provides auto-fetch features

Atchuthan
on 5/24/13, 5:38 AM

Did that. No effect.

Gerry
on 6/6/13, 11:01 PM

Here are the commands I use to update OpenERP to the latest version. Then following a reboot of the server, that's when the Fetchmail action stops working. The working version of OpenERP is 7.0-20130319-002358. Even the latest version 7.0-20130606-231042 does not work. Thank you in advance for any suggestions.

Gerry
on 6/6/13, 11:06 PM
0
Martin Temmink
On 9/15/14, 8:51 AM

"the last fetch date" is showing only the last SUCCESFULL time and date the system was able to fetch e-mail.

With other words, it might try to fetch just every few minutes, but has maybe a problem to succesfully end the the fetch process. 

Just check your logfile/console to see if you see that the fetchmail is executed. If it executes, but gives an error, you proberly have to remove the first e-mail in your e-mail box. (I had one with some strange spam garbage in it, wich causes fetchmail to abort, had something to do with wrong UTF-8 encoding). If you are paying attention to the console, and try to force the fetch you can actually see what happens.

After removing the e-mail which was causing this, all went well. 

0
Malte Helmhold
On 9/15/14, 6:43 AM

I'm searching for this automated actions everywhere in 8.0dev-20140416-230101

I can see under apps that a plugin "  

Automated Action Rule " is installed, but I can't see any hint to neither "schudule", "automation" nor fetchmail in my "Settings" 

so where can I search to get the settings of the automated tasks in Odoo v8? 

all the best for you guys!

Ok, I found out that you have to check for the admin or the user you want to enable the feature in order to see this settings: User Permissions -> Technical features without this enable the user can't see the settings needed for properly configure openERP. That's something an OpenERP beginner has to do hard work to find out! alas

Malte Helmhold
on 9/17/14, 8:24 AM
0

Cameron

--Cameron--
769
| 6 5 8
United Kingdom
--Cameron--
Cameron
On 6/20/13, 11:52 AM

Worked for me....

I went to Setting>Modules>Installed Module>Base and Upgraded

Dont know what happened but its working again!

I lost a few settings - mainly modified views and search filters - small price to pay

Cameron
on 6/26/13, 7:36 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

3 follower(s)

Stats

Asked: 5/16/13, 8:21 PM
Seen: 7138 times
Last updated: 7/8/15, 1:42 AM