Odoo Help


Email fails to reach destination (OpenERP7)

on 5/9/13, 9:27 AM 3,781 views


I am trying to set the Outgoing mailing server settings in OpenERP7 so that it can use our company's Outgoing Mailing Server. The connection test is successful but when I try to send an email, it looks like it's sent but when I open my mail box it doesn't receive anything.

I tried the Gmail SMTP and it's working perfectly!

My company's outgoing mailing server settings are something like this:

SMTP Server: mail.mycompany.com

Port: 587

Security: None

Login: mylogin

Password: **

How can I fix that?


Your question is ambiguous. Are you saying you got it working with Gmail SMTP, but now want instead to use your own SMTP?

on 5/9/13, 9:40 AM

Yes Martin that's it! The connection test is successful with my own SMTP but when I send emails they don't reach destination

on 5/9/13, 9:41 AM

Can you review the logs of your internal SMTP server?

on 5/9/13, 9:47 AM

No I can't Martin sorry I do not have full access to the SMTP server

on 5/9/13, 9:52 AM

I don't see how you can get any further with this until you learn from your SMTP logs whether it is configured to permit what you are trying to do.

on 5/9/13, 10:10 AM



| 5 6 8
Cornwall, Canada

Analysing, designing, coding and mentoring since 1975. Kilobytes to terabytes. Punch cards to punchy sites. My OpenERP video series: http://www.youtube.com/playlist?list=PLq7op4J183lX44ZlXPiHxUpRvmmRDtxye My Google Speadsheets --> OpenERP Data Pump project: http://martinhbramwell.github.io/GData_OpenERP_Data_Pump My email (with spaces removed) : mhb . warehouseman @ gmail . com

On 5/9/13, 9:46 AM

You do not mention changing the Priority field. Could that be the problem?

When OpenERP sends an email it uses the recorded SMTP service with the lowest Priority number.

It is not completely clear to me whether this is relevant, but since it's only 2 mins long, this video might help:

Google OAuth Demo: Step #3 SMTP setup so as to invite UID/PWD users to use OAUth.

I made it to show how to use Google OAuth, but it also demonstrates outgoing mail set up.

I did not change the priority it is still at 10. I don't even know what is it for to be honest!

on 5/9/13, 9:48 AM

Answer updated.

on 5/9/13, 9:53 AM

I followed all the steps mentioned in the video It works perfectly with Google SMTP but I want to use my own SMTP and when I test the connection, the test is successful but when I send the email, it doesn't reach it's destination

on 5/9/13, 10:03 AM

It seems as if your local SMTP server is accepting connections, but refusing to send mail from an unregistered sender.

on 5/9/13, 10:14 AM

I am using an account that is registered in that mailing server.

on 5/9/13, 2:00 PM

Yes, of course you are, or it would have refused the connection. But that still doesn't mean that your current activity is permitted. In my opinion this is not your problem -- it is the mail server sysop's problem.

on 5/9/13, 3:55 PM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

2 follower(s)


Asked: 5/9/13, 9:27 AM
Seen: 3781 times
Last updated: 3/16/15, 8:10 AM