Odoo Help

0

0
2 Answers
4
Roc cheng
4/22/14, 4:43 AM

Hi, In my opinion,2 ways solved it: 1. change the field's attribute of the order object, exmpale:

'shop_id': fields.many2one('sale.shop', 'Shop', required=True, readonly=True, states={'draft': [('readonly', False)], 'sent': [('readonly', False)]}),

only the draft and sent state the fields can be edited

2. add access rule for the object

Settings >> Technical >> Security >> Record Rules

remove Apply for Write..

then set the domain filtter example:

 [('state', '=', 'Quotation')]...

Hope it wil help you

0
Avatar

Jagdish Panchal

--Jagdish Panchal--

2713
| 5 4 6
Gandhinagar, India
--Jagdish Panchal--

OpenERP Developer

Jagdish Panchal
4/22/14, 2:46 AM

HI,

Go in Settings >> Technical >> Security >> Access Controls List

Search Purchase you file find access control list for purchase order remove write access as show in screen shot.

To see screen shot click here

2 Comments
Roc cheng
4/22/14, 4:20 AM

Hi,Jack,The way you did is not good, remove access control list for object,you will not change the order even it just on draft state

Jagdish Panchal
4/22/14, 4:24 AM

@Roc cheng : Then which way we do that ?

Ask a Question
Writer
Keep Informed
0 follower(s)
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register
Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now