Odoo Help

2

5
7 Answers
2
Ana Cristina Ponce Mexico
8/13/13, 12:08 PM

Yes it does

1
Xsias France
8/5/13, 10:13 AM

Yes he can. We have a customer who has more than 500k products His OpenERP instance runs pretty well.

EDIT

For exemple, we have put the database on a SSD. (not a 15k rpm hd)

1 Comment
Daniel Reis Portugal
8/13/13, 3:18 PM

Surely you went through some optimization work. Can you edit the answer to share some more details?

0
Sohail India
8/12/13, 5:22 AM

The True fact is that the system loads slowly when started for the first time due to very high number of products. Also if your number of products is so high then you should be depending on the system configuration of your PC (amount of RAM and CPU..) Also the sales order and other data affect the system performance if you are using version 6.1 or less of OpenERP. Do not clear cache of browser if pages are cached it will help with loading the application faster for frequently visited pages only.

0
Steve Smith United Kingdom
8/5/13, 10:18 AM

I have 170,000 and having search issues - not finding products when searching for them.

Wonder how the guy with 500k has got round the issues.

8 Comments
Xsias France
8/5/13, 10:28 AM

Good servers.

Steve Smith United Kingdom
8/5/13, 11:19 AM

not sure what else can add to my servers. Got the db on a fast drive, 12gb ram, 4cpu :/

Laura Jarvenpaa China
8/6/13, 7:59 AM

Have you optimized you postgres configuration file?More info: wiki.postgresql.org/wiki/Tuning_Your_PostgreSQL_Server (can't post links so removed http part).

Steve Smith United Kingdom
8/6/13, 10:38 AM

Will be my next port of call. Many thanks.

Xsias France
8/12/13, 5:35 AM

We have put the database on a SSD. It's amazingly fast.

Ray Carnes United States
8/18/13, 3:14 PM
Steve Smith United Kingdom
9/5/13, 11:05 AM

Changing the settings in Postgres helped massively :)

Ray Carnes United States
9/6/13, 8:52 PM

Can you share what you changed?

0
Avatar

Gustavo Argentina

--Gustavo--
1000
| 2 2 6
Buenos Aires, Argentina
--Gustavo--

Python developer, big fan of sailing

Gustavo Argentina
8/6/13, 6:46 PM

Change the view_list.js code and remove the options available to end user. Limit the number of rows a user is able to see each time he/she opens s a view. That will help you reduce the workload on the server

0
Flyguy Belgium
8/6/13, 12:25 PM

We have a customer with 700K products. It was very slow, so we had to do some customization, especially on the search funtion. But it works fine now.

3 Comments
adi India
8/13/13, 10:59 AM

Hi can you please elaborate on the customizations you have done for the search function as we are facing a similar issue.

Steve Smith United Kingdom
9/6/13, 9:37 PM

just raised the postgres cache to 4gb

Steve Smith United Kingdom
9/6/13, 9:38 PM

that was only for 200k products

0
adi India
8/13/13, 11:09 AM

Also I found this very helpful

Ask a Question
Writer
Keep Informed
0 follower(s)
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register
Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now