Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Display all quotations by default

By
Neil
on 2/5/15, 8:46 AM 875 views

In Odoo v8, when I click quotations, it shows the quotations that my user created by default. Is there a way to show all quotations by default? (Remove the 'My' filter?).

Thanks!

1

Emipro Technologies Pvt. Ltd.

--Emipro Technologies Pvt. Ltd.--
Tiny ERP Pvt Ltd
http://www.odoo.com
5975
| 6 7 8
Rajkot, India
--Emipro Technologies Pvt. Ltd.--

Being an emerging leader in IT market since 2011, Emipro Technologies Pvt. Ltd. has been providing a wide range of business solutions in Odoo & Magento. We are pleased to have a large pool of contented customers with our meticulous work in the domain of ERP & e-Commerce. A ray of relief & satisfaction to  our customers heart by our successful deployment in their organization, purely represents our success in Odoo platform. Hence, we take pride for being an Odoo partner with a vision of expanding our strategic alliances with our customers to offer them high value-added, trustworthy & cost effective solutions.

 

Since establishment, our business has span across 11 countries of the world. Our customers are companies of all sizes ranging from start-ups to large enterprises, who realize that they need a professional business solutions to generate revenue streams, establish proper communication channels or streamline business operations. Standing with strong determination of customer satisfaction, observing each minute detail of their business processes, providing proper guidance and moving forth to develop product accordingly adds our value and reliability among our customers. 

 

We are blessed with efficient, passionate & eclectic young developers who have come across almost all kinds of business profiles, working with full dedication, applying creativity & new features in existing modules and completing customer's projects successfully on predefined target. Our in-depth knowledge while giving business solutions in Odoo allows us to offer following services to our customers :

 

  • Consulting
  • Installation, Configuration & Customization
  • Training & Support
  • Maintenance
  • Upgradation
  • Documentation
  • Crafting community modules
  • Drafting videos on demand
  • Smart Apps development

We will be :) to welcome you @ www.emiprotechnologies.com to solve any kind of your business needs around Odoo. However we are just an inch away from you by email info@emiprotechnologies.com or a tweet to @EmiproTech

Emipro Technologies Pvt. Ltd.
On 2/5/15, 8:51 AM

Try the following:

Edit

You can replace the filter by following:

<filter name="my_sale_orders_filter" position="replace"/> ... but it may not work

So try the following..

Over ride the action and remove the attribute from the context menu

        <record id="sale.action_orders" model="ir.actions.act_window">
            <field name="name">Sales Orders</field>
            <field name="type">ir.actions.act_window</field>
            <field name="res_model">sale.order</field>
            <field name="view_type">form</field>
            <field name="view_mode">tree,form,calendar,graph</field>
            <field name="search_view_id" ref="sale.view_sales_order_filter"/>
            <field name="context">{}
            </field>
            <field name="domain">[('state', 'not in', ('draft', 'sent', 'cancel'))]</field>
            <field name="help" type="html">
                <p class="oe_view_nocontent_create">
                    Click to create a quotation that can be converted into a sales
                    order.
                </p><p>
                    Odoo will help you efficiently handle the complete sales flow:
                    quotation, sales order, delivery, invoicing and payment.
                </p>
            </field>
        </record>

Hope this helps !!.

I would agree that this should work, but for me it doesn't. I did this and even checked in Odoo -> Settings -> Actions -> Window Actions -> Search for 'quot' -> Open the action, there I can see that context = '{}' but when I go to the quotations menu I still get the 'My' filter. A workaround for this is clearing all filters and then choose save current filter then check use as default. The only problem here (AFAIK) is that you will have to do this for every user. So in systems where there are a lot of users with access to sales, it will be a hell of an edit (for me at least, since I dislike manual, repetitive jobs).

Cats&Dogs bvba, SonnyV
on 10/1/15, 12:02 PM

Ok, my bad. I forgot to add the very important 'sale.' before my action_id, resulting in my custom module creating another window action. It is fixed now.

Cats&Dogs bvba, SonnyV
on 10/1/15, 12:08 PM
1
Bruno JOLIVEAU
On 2/6/15, 2:30 PM

Hi,

You can customize and save your view without this filter.

 

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 2/5/15, 8:46 AM
Seen: 875 times
Last updated: 3/16/15, 8:10 AM