Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


DeprecationWarning: Mapper.convert() after installing Magento Camptocamp OpenERP Connector

Michael Moster
on 3/19/14, 12:52 PM 1,490 views

installed and try to use this connector. Get the following error messages :

Traceback (most recent call last): File "/home/openerp/openerp_7.0/openerp-connector/connector/queue/worker.py", line 122, in run_job job.perform(session) File "/home/openerp/openerp_7.0/openerp-connector/connector/queue/job.py", line 472, in perform self.result = self.func(session, self.args, *self.kwargs) File "/home/openerp/openerp_7.0/openerp-connector-magento/magentoerpconnect/unit/import_synchronizer.py", line 329, in import_record importer.run(magento_id, force=force) File "/home/openerp/openerp_7.0/openerp-connector-magento/magentoerpconnect/unit/import_synchronizer.py", line 174, in run self._import_dependencies() File "/home/openerp/openerp_7.0/openerp-connector-magento/magentoerpconnect/sale.py", line 649, in _import_dependencies self._import_addresses() File "/home/openerp/openerp_7.0/openerp-connector-magento/magentoerpconnect/sale.py", line 567, in _import_addresses mapper.convert(customer_record) File "/home/openerp/openerp_7.0/openerp-connector/connector/unit/mapper.py", line 717, in convert raise DeprecationWarning('Mapper.convert() has been deprecated, ' DeprecationWarning: Mapper.convert() has been deprecated, use Mapper.map_record() then map_record.values()

anybody knows what to do ? Thanks



| 5 2 8
Ahmadabad, India
On 3/20/14, 1:16 AM


This might be due to incompatible module with the last version of the Connector Framework.

You may refer the link if it may help you: https://accounts.openerp.com/forum/Help-1/question/43979

thanks for the reply Nehal. Forgot to specify that we are connecting Magento to OpenERP. The module is the one suggested in the instatallation guide of the connector homepage.

Guenstig.de Shopping Kg, Michael Moster
on 3/20/14, 5:20 AM

Nehal is correct, you probably use an old revision of the magentoerpconnector module on a more recent revision of the connector. Update the modules to their latest revisions or to their latest tags and you should be ok. See also http://openerp-magento-connector.com/guides/installation_guide.html

Camptocamp SA, Guewen Baconnier - Software Developer, Camptocamp
on 3/21/14, 10:44 AM

the installation was done according to the installation guide of the adress you mentioned, so that cannot be the problem. $ bzr branch lp:magentoerpconnect/magento-module-oerp6.x-stable magento-module , so I don't think this is the problem

Guenstig.de Shopping Kg, Michael Moster
on 3/26/14, 6:16 AM

What are the revisions ids of the branches openerp-connector, openerp-connector-ecommerce, openerp-connector-magento? You can get them with the command bzr version-info --custom --template="{revision_id}\n"

Camptocamp SA, Guewen Baconnier - Software Developer, Camptocamp
on 3/28/14, 4:33 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)


Asked: 3/19/14, 12:52 PM
Seen: 1490 times
Last updated: 3/16/15, 8:10 AM