Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Database from Odoo 8RC1 can't use after upgrade to Odoo 8.0 stable version.

By
Sebastian Wrona
on 9/29/14, 12:27 PM 1,152 views

Hello,

I've made Odoo 8RC1 upgrade from version 8.0RC1 to 8.0. The process went smoothly, but… databases made under RC1 version of Odoo doesn’t work with the final stable version of Odoo. When I choose a database created in 8.0 RC1 version I get an ‘Intrnal Server Error’. In the Odoo log file can’t read any specific solution… Any idea how to use these databases in the final 8.0 Odoo version?

Or is there a possibility to downgrade Odoo again to versio RC1? How to do it? I need data sored in databases to which I have no access now :(

Please help.  

Sebastian

2014-09-29 15:34:33,699 550 INFO hadron_one werkzeug: 89.76.132.187 - - [29/Sep/2014 15:34:33] "GET /web/login?redirect=http%3A%2F%2Fhadron.eu.com%2Fweb%3Fdb%3Dhadron_one HTTP/$

2014-09-29 15:34:33,824 550 ERROR hadron_one werkzeug: Error on request:

Traceback (most recent call last):

  File "/usr/lib/python2.7/dist-packages/werkzeug/serving.py", line 177, in run_wsgi

    execute(self.server.app)

  File "/usr/lib/python2.7/dist-packages/werkzeug/serving.py", line 165, in execute

    application_iter = app(environ, start_response)

  File "/opt/odoo/odoo-server/openerp/service/server.py", line 280, in app

    return self.app(e, s)

  File "/opt/odoo/odoo-server/openerp/service/wsgi_server.py", line 216, in application

    return application_unproxied(environ, start_response)

  File "/opt/odoo/odoo-server/openerp/service/wsgi_server.py", line 202, in application_unproxied

    result = handler(environ, start_response)

  File "/opt/odoo/odoo-server/openerp/http.py", line 1214, in __call__

    return self.dispatch(environ, start_response)

  File "/opt/odoo/odoo-server/openerp/http.py", line 1188, in __call__

    return self.app(environ, start_wrapped)

  File "/usr/lib/python2.7/dist-packages/werkzeug/wsgi.py", line 579, in __call__

    return self.app(environ, start_response)

  File "/opt/odoo/odoo-server/openerp/http.py", line 1360, in dispatch

    response = self.get_response(httprequest, result, explicit_session)

  File "/opt/odoo/odoo-server/openerp/http.py", line 1295, in get_response

    result = request.registry['ir.http']._handle_exception(e)

  File "/opt/odoo/odoo-server/addons/website/models/ir_http.py", line 194, in _handle_exception

    attach = self._serve_attachment()

  File "/opt/odoo/odoo-server/addons/website/models/ir_http.py", line 168, in _serve_attachment

    attach = self.pool['ir.attachment'].search_read(request.cr, openerp.SUPERUSER_ID, domain, ['__last_update', 'datas', 'mimetype'], context=request.context)

  File "/opt/odoo/odoo-server/openerp/api.py", line 237, in wrapper

    return old_api(self, *args, **kwargs)

  File "/opt/odoo/odoo-server/openerp/models.py", line 5026, in search_read

    record_ids = self.search(cr, uid, domain or [], offset=offset, limit=limit, order=order, context=context)

  File "/opt/odoo/odoo-server/openerp/api.py", line 237, in wrapper

    return old_api(self, *args, **kwargs)

  File "/opt/odoo/odoo-server/addons/calendar/calendar.py", line 1724, in search

return super(ir_attachment, self).search(cr, uid, args, offset=offset, limit=limit, order=order, context=context, count=count)

  File "/opt/odoo/odoo-server/openerp/api.py", line 237, in wrapper

    return old_api(self, *args, **kwargs)

  File "/opt/odoo/odoo-server/addons/document/document.py", line 87, in search

    ids = super(document_file, self).search(cr, uid, args, offset=offset, limit=limit, order=order, context=context, count=False)

  File "/opt/odoo/odoo-server/openerp/api.py", line 237, in wrapper

    return old_api(self, *args, **kwargs)

  File "/opt/odoo/odoo-server/openerp/models.py", line 1691, in search

    return self._search(cr, user, args, offset=offset, limit=limit, order=order, context=context, count=count)

  File "/opt/odoo/odoo-server/openerp/api.py", line 237, in wrapper

    return old_api(self, *args, **kwargs)

  File "/opt/odoo/odoo-server/openerp/addons/base/ir/ir_attachment.py", line 253, in _search

    access_rights_uid=access_rights_uid)

  File "/opt/odoo/odoo-server/openerp/api.py", line 237, in wrapper

    return old_api(self, *args, **kwargs)

  File "/opt/odoo/odoo-server/openerp/models.py", line 4556, in _search

    cr.execute(query_str, where_clause_params)

  File "/opt/odoo/odoo-server/openerp/sql_db.py", line 158, in wrapper

    return f(self, *args, **kwargs)

  File "/opt/odoo/odoo-server/openerp/sql_db.py", line 234, in execute

    res = self._obj.execute(query, params)

InternalError: current transaction is aborted, commands ignored until end of transaction block

Sorry for double posting the same problem. Not enough karma to delete :/

Sebastian Wrona
on 9/29/14, 12:31 PM
4

Openies Services

--Openies Services--
925
| 2 2 4
Vadodara, India
--Openies Services--

We provide Odoo Services.

Contact us on : contact@openies.com

Openies Services
On 9/29/14, 2:07 PM

May be upgradation of "base" module will solve the problem. Try to upgrade the "base" module.

0
Martin Temmink
On 9/29/14, 5:06 PM

After de update from github, please do the following: (assuming it's linux based)

  1. Stop de odoo service
  2. go to the location of your odoo installation (e.g. /opt/odoo/server)
  3. ./odoo-server  -d name of te database -u all.         
  4. Watch the console for errors/warnings.
  5. Hit ctrl-c
  6. Resart de odoo services

Hopefully it solves your problem, The command will try to make sure (upgrade) your current database which is 8.0rc1 to the 8.0 version.

 

If you find this answer helpfully, please give a thumbs-up vote!

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 9/29/14, 12:27 PM
Seen: 1152 times
Last updated: 3/16/15, 8:10 AM