Odoo Help

0

"Database creation error: Access denied" when acessing remote Postgre base

By
Marcio Ribeiro
on 11/7/16, 8:56 AM 537 views

Using Odoo 9.0 and PostgreSQL 9.5.

I want to use Odoo in a remote PostgreSQL server. Both services are in different Cloud servers hosted on Digital Ocean. I already tried:

  • Changing the pg_hba.conf and postgresql.conf to listen to all addresses and hosts in the PostgreSQL Server machine.

  • Creating odoo user in postgres with superuser and createdb permissions.

  • Changing both the openerp-server.conf at /opt/odoo/odoo-server/debian and /etc/odoo/. Adding the db_host, db_port, db_user and db_password accordingly. Also tried removing the comment symbol from the line  "admin_passwd = admin" and using it as master password when acessing Odoo for the first time.


This covers basically all the solutions suggested in other threads about this same problem.

Anyone got any clues ?

Any help is highly appreciated!



0
Marcio Ribeiro
On 11/7/16, 12:05 PM

I found the solution! When prompted for the Master Password in the moment of creating the db I wasn't inserting the proper one.

Ivan answer in this thread helped me figured it out:

https://www.odoo.com/es_ES/forum/ayuda-1/question/acess-denied-error-while-creating-a-company-database-73979

In this step you are supposed to use the Odoo password for database operations.


@Ermin Trevisan Thanks for your help, appearently the firewall presented no problem at all.

0

Ermin Trevisan

--Ermin Trevisan--
4802
| 6 4 7
Walchwil, Switzerland
--Ermin Trevisan--


Ermin Trevisan
On 11/7/16, 11:42 AM

Maybe stupid, but did you open port 5432 in the firewall of your Postgres-server?

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 11/7/16, 8:56 AM
Seen: 537 times
Last updated: 11/7/16, 12:36 PM