Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


damn wkhtmltopdf ...

on 10/5/14, 2:47 AM 905 views

Windows Server 2012 installation.

Done PATH=C:\progra~1\wkhtmltopdf\bin

Done webkit_path=C:\progra~1\wkhtmltopdf\bin\wkhtmltopdf.exe

Not working...what i can control?



Ben Bernard

--Ben Bernard--
| 4 3 6
Jakarta, Indonesia
--Ben Bernard--
Ben Bernard
On 10/6/14, 5:20 AM

Odoo 8 use report module by default and it's not using webkit_path. webkit_path is used in report_webkit module. Historically, odoo 8 move to support generating report with wkhtmltopdf by default and implement it in report module. The report module itself use PATH environment variable to determine the wkhtmltopdf binary.

I'm not a fan that use PATH environment variable. So, I create this patch [1] for odoo 8 that add webkit_path option to odoo's configuration. To define path to wkhtmltopdf executable define webkit_path in configuration file .conf, like so.

webkit_path = C:\progra~1\wkhtmltopdf\bin\wkhtmltopdf.exe


[1] https://gist.github.com/bbn-bernard/b87b24d23006c29978f5



| 5 3 6
Jakarta, Indonesia
On 10/5/14, 8:42 PM

Seriously: move to Linux.  On the side node, check from your command line whether wkhtmltopdf --help returns anything.  If not, you need to include the path to the executable in your PATH environment variable.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)


Asked: 10/5/14, 2:47 AM
Seen: 905 times
Last updated: 3/16/15, 8:10 AM