Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Custom Installer, Server error Path not found / How do I rectify this?

By
Harish Ved
on 4/2/14, 8:23 AM 1,643 views

I wanted to make a custom OpenERP 6.0 installer for windows.

I followed all the instructions given at developer page of 6.0 openerp at /8_24_build/ and made 2 exe files - one for web client and one for server.

The problem is that after installation of these exe files in windows, I checked for running postgresql server and web client in Computer -> Manage -> Services and I have a running server script (checked in task manager) by running - 'openerp-server.exe -d openerpdemo -r openpg -w openpgpwd --db_host=localhost logfile="C:\Users\Something\Desktop\d33mo_db.log" --db_port=5432' in cmd prompt.

I have set up postgresql database openerp with user openpg and password openpgpwd (this all can be checked in pgadmin3).

But still on navigating to localhost:8069 (without any proxy) I am getting "server not found"

the log message is - "

[2014-04-01 19:20:22,732][?] INFO:server:OpenERP version - 6.0.4

[2014-04-01 19:20:22,732][?] INFO:server:addons_path - C:\Program Files (x86)\OpenERP 6.0\Server\addons

[2014-04-01 19:20:22,733][?] INFO:server:database hostname - localhost

[2014-04-01 19:20:22,733][?] INFO:server:database port - 5432

[2014-04-01 19:20:22,733][?] INFO:server:database user - openpg

[2014-04-01 19:20:22,733][?] INFO:server:initialising distributed objects services

[2014-04-01 19:20:23,015][?] INFO:web-services:starting HTTP service at 0.0.0.0 port 8069

[2014-04-01 19:20:23,016][?] INFO:web-services:starting HTTPS service at 0.0.0.0 port 8071

[2014-04-01 19:20:23,016][?] INFO:web-services:Registered XML-RPC over HTTP

[2014-04-01 19:20:23,017][?] INFO:web-services:starting NET-RPC service at 0.0.0.0 port 8070

[2014-04-01 19:20:23,052][openerpdemo] INFO:init:module base: loading objects

[2014-04-01 19:20:23,052][openerpdemo] INFO:init:module base: registering objects

[2014-04-01 19:20:23,247][openerpdemo] INFO:server:Starting 3 services

[2014-04-01 19:20:23,249][openerpdemo] INFO:server:OpenERP server is running, waiting for connections...

[2014-04-01 19:27:22,206][?] ERROR:http:code 404, message Path not found: /

[2014-04-01 19:27:22,206][?] ERROR:init:Server error in request from ('127.0.0.1', 50895):

Traceback (most recent call last):

File "SocketServer.pyo", line 222, in handle_request

File "SocketServer.pyo", line 241, in process_request

File "SocketServer.pyo", line 254, in finish_request

File "service\websrv_lib.pyo", line 246, in __init__

File "SocketServer.pyo", line 522, in __init__

File "BaseHTTPServer.pyo", line 316, in handle

File "service\websrv_lib.pyo", line 434, in handle_one_request

File "service\websrv_lib.pyo", line 181, in send_error

AttributeError: MultiHandler2 instance has no attribute 'error_content_type' "

So, is the problem in the binary setup files of the server and/or the web client or the problem is of the configuration in windows? What shall I do to access openerp server at localhot:8069?

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 4/2/14, 8:23 AM
Seen: 1643 times
Last updated: 3/16/15, 8:10 AM